So I'm running Magento 2.1.5 and I have installed a MagePal extension which sends email through Amazon SES.

If the system sends any emails from anywhere everything works fine. But if I am creating an order I get an error.

If I create an order as a customer, it just comes back:

An error occurred on the server. Please try to place the order again

This has been throwing me for a loop and I have no idea what is going on.

But then I placed an order from the admin and get an error also but it's a bit different. It says:

Invalid MAIL FROM address provided

So it seems to be an error maybe from Amazon SES? However, all other emails I send are fine, if I change a password the user gets notified, I send a test, it comes through, if I "forgot password", it works. I'm stumped and I don't have much else to go on, if someone has any ideas of even where to look.

  • Can you check under Stores > Configuration > Sales > Sales Emails and check which email sender is selected for the New Order Confirmation Email Sender option. Then check the value of this sender in Stores > Configuration > General > Store Email Addresses. Make sure the email address is configured to send from your verified domain in Amazon SES. Commented Feb 25, 2017 at 3:33
  • Yeah, I have everything set to the same email, and with Amazon SES both the domain and the individual email is verified. Emails from every other situation work fine, but never when an order is being placed. Commented Feb 28, 2017 at 22:00

2 Answers 2


I never could resolve this issue. Since we are using Google Apps for our email, we just switched it to send email through that service. Which negates the issue of the from address needing to be verified.

From testing it seems the from address is never set at all when orders are placed, I do not know why.

Additional information: We are running multistore, however it's all the same company and everything so both stores all use the exact same email.


This is not a solution but could be a workaround or starting point of debugging for someone. This extension is conflicting with the Amazon modules Magento added in recent release. I faced the similar problem and after disabling those modules (as I'm not using any of these modules for now).

php bin/magento module:disable Amazon_Core Amazon_Login Amazon_Payment

Reference Link

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.