0

I am getting below error :

Uncaught TypeError: a is not a function
    at d.initialize (prototype.js:1)
    at new d (prototype.js:1)
    at Object.openDialog (browser.js:48)

When insert image from admin editor and the popup window is blank.

enter image description here

How can I solve the issue? I a using magento 1.9.0.1

  • Do you have JS merging enabled? If so, please disable it and check if the issues is fixed then. If that's the case, you have an error in one of the JS files (missing a ; at the end of a line/file or something), which needs to be fixed. – Arjen Miedema Feb 24 '17 at 7:15
  • No, I have not merged JS files – Vinod Kumar Feb 24 '17 at 9:27
  • In that case you might want to check line 48 of browser.js and then check what's wrong with the way this script is called on the page you're currently viewing. – Arjen Miedema Mar 2 '17 at 6:46
0

Ran into the same error after minifying my prototype.js and browser.js. feeding the code through a css unminifier will not work, only way to correct this is to contact your web host and have them reinstall the original files or do so yourself. Good luck

0

I get the same empty Insert Image... window when I clicked on Browse button. But before that empty window I get a error message that say:

error in [unknown object].fireEvent():

event name: open_browser_callback

error message: e is not a function

So when i read this answer i remember that I also minify prototype.js. But before I minify that file i made a back up copy of it. So I go get the backup copy and restore it. Then I clear the Magento (version 1.9.2.4) and browser cache, refresh the page and all was back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.