0

I need to alter the Blog url in the "The Checkout | Blog | Login/Register" block that is referenced in the

theme/template/page/html/header.phtml

I have looked everywhere and cannot find it. All I need to do is change the http to https for the blog link which was a customisation put in by my ex-developer

In the /header.phtml, this is part of the code that calls it, but I can't find where I can edit either the topContainer or topMenu. I iave looked in most/layout .xml's as well and cannot find anything there.

<?php echo $this->getChildHtml('topContainer'); ?>
 <div id="nav-top">
    <div class="container">
        <?php echo $this->getChildHtml('topMenu') ?>
    </div>
 </div> 

IT is driving me mental!

  • is there any extension check layout file in that layout they mention – Magento 2 Feb 19 '17 at 13:35
  • Im not sure what you mean sorry! – Paul Wallace Feb 20 '17 at 14:26
  • Is it any Extension or you custom code – Magento 2 Feb 20 '17 at 15:26
  • I am fairly sure it was code that was customised by my old developer, but I cant find any evidence of it in any of the page/html files – Paul Wallace Feb 20 '17 at 16:05
  • I found it in wordpress.xml, but but I need to change the link to https from http, but I cant do it from that – Paul Wallace Feb 20 '17 at 16:24
0

Check in your

app\design\frontend\theme\default\layout\page.xml

May be you will find under

<block type="page/html_header" name="header" as="header">

if still not able to find then search the Keyword "Blog" in your project, to search in whole project clone the project in your local machine and search using NetBans in whole project or any other editor which you have installed.

  • thanks, but it is not in app\design\frontend\theme\default\layout\page.xml I did download NetBans but I have no idea how to use it or get it set up it looks really complicated? – Paul Wallace Feb 20 '17 at 15:05
  • I have just done a search via windows of the files, and found this in wordpress.xml <reference name="top.links"> <action method="addLink" translate="label title" module="wordpress" ifconfig="wordpress/toplink/enabled"> <label helper="wordpress/getTopLinkLabel" /> <url helper="wordpress/getTopLinkUrl"/> <title>Blog</title> <prepare>0</prepare> <urlParams /> <position helper="wordpress/getTopLinkPosition" /> <li_params /> <a_params>class="top-link-blog"</a_params> </action> </reference> but I still cant change the URL to https instead of http – Paul Wallace Feb 20 '17 at 16:18
  • In app\code\community\Fishpig\Wordpress\Helper\Data.php around line 25 Replace : <br/> $transport = new Varien_Object(array('toplink_url' => $this->getUrl())); To: transport = new Varien_Object(array('toplink_url' => $this->getUrl('', array('_secure' => true)))); after this clear your cache and try Note: File path may change in your environment if you modified the extension files – aman Feb 22 '17 at 3:45
  • Is it worked for you? – aman Feb 23 '17 at 2:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.