0

I would like to update Magento 2 from 2.1.3 to 2.1.4. While readiness check I get this error and hint:

PHP Settings Check *

Your current PHP memory limit is 256M. Magento 2 requires it to be set to 756M or more. As a user with root privileges, edit your php.ini file to increase memory_limit. (The command php --ini tells you where it is located.) After that, restart your web server and try again.

*In some cases, you might have two PHP configuration files: one for the PHP command line and for the web server. If so, make the change in both php.ini files. For details, see the php.ini reference.

When I look at the phpinfo info page it’s correct:

memory_limit 768M

with php —ini I get this path’s:

[~/www/magento]# php --ini
Configuration File (php.ini) Path: /opt/alt/php56/etc
Loaded Configuration File:         /opt/alt/php56/etc/php-cli.ini
Scan for additional .ini files in: /opt/alt/php56/link/conf
Additional .ini files parsed:      /opt/alt/php56/link/conf/alt_php.ini

PHP.ini file for php-cli

[~/www/magento]# php -i |grep php\.ini
Configuration File (php.ini) Path => /opt/alt/php56/etc
Additional .ini files parsed => /opt/alt/php56/link/conf/alt_php.ini

in php.info i get this path’s

Configuration File (php.ini) Path   /opt/alt/php56/etc
Loaded Configuration File   /opt/alt/php56/etc/php.ini
Scan this dir for additional .ini files :/home/xxx/etc/php_settings/conf.d
Additional .ini files parsed    /opt/alt/php56/link/conf/alt_php.ini, /home/xxx/etc/php_settings/conf.d/00-mycyon.ini

It is not my own webserver, so I can only edit this file:

/home/xxx/etc/php_settings/conf.d/00-mycyon.ini

The hosting provider says the 00-mycyon.ini file overwrite the others.

But I get still the same error.

How can I find the right php.ini file which magento use? Or is it possible to say magento that it take this php.ini file: /home/xxx/etc/php_settings/conf.d/00-mycyon.ini

Thanks for every hint or idea!

  • I know, thats not the answer, but consider upgrading to PHP7. This MIGHT solve your problem. – Max Feb 16 '17 at 13:57
  • Thanks for you answer. I already tried to update but than i have the same problem. Phpinfo shows php Version 7 but Magento still show Version 5.6. I think the problem is that they use different php.ini files. – Ayline Feb 16 '17 at 15:49
0

I found a solution. Maybe it is also helpful for someone else.

I found this info: http://magento-quickies.alanstorm.com/post/152908661755/your-current-php-memory-limit-is-128m-and-other

The problem is that the Readiness Check is dependent on the Cronjob.

The cronjob was displayed to me as correct, but it pointed to another php version than I thought.

So I changed it from:

/usr/local/bin/php /home/pitecch/public_html/magento/bin/magento cron:run | grep -v "Ran jobs by schedule" >>

to

php -c /home/xxx/etc/php_settings/conf.d/00-mycyon.ini /home/pitecch/public_html/magento/bin/magento cron:run | grep -v "Ran jobs by schedule" >>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.