1

The product url keys not working, sometimes they do suddenly it goes to the original url like: https://www.takoda.shop/nl/catalog/product/view/id/5/s/dog-tag-halsketting-messing/category/5/

and not as I prefer that is stays like this: https://www.takoda.shop/nl/dog-tag-halsketting-messing.html

Where is that all about?

Also

When I want to change the content of the dutch store view of a category it say: URL key for specified store already exists.

So there is obviously something wrong here

Anybody got any experience with solution this sort?

Thanks a lot in advance

The url keys for the products are alright again when I export all products and import them all, but that doesn't seem to be the way it has to work, is it ? In terms of emergency it can work like that until the real solution appears

enter image description here

5
  • It might be an indexing issue. Did you setup the magento crons? Feb 14, 2017 at 11:18
  • @kevin-ramen thanks for you comment, I have put my cron jobs print screen picture, am I missing something? Feb 14, 2017 at 11:45
  • Seems good. In system->index management, are you indexers "ready" or "index required" ? Feb 14, 2017 at 12:31
  • Concerning the url already exists, I know there was a bug in magento 1.x where you could not have the same url in two different stores. That is the urls must be unique across all stores. I don't know if it is the case in magento 2 as well. Feb 14, 2017 at 12:32
  • @kervin-ramen Yes the indexers are ready, I understand but the url is different for every store view ... Feb 14, 2017 at 13:10

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.