0

I successfully implemented SSL on our website and went the LetsEncrypt to get my CA. All is set properly and in working order except one weird issue I am encountering post enabling.

Your web server is configured incorrectly. As a result, configuration files with sensitive information are accessible from the outside. Please contact your hosting provider.

I followed the instructions found via documents, articles, etc to enable SSL, set base URL and Secure URL to "https://", SSL_OFFLOADED and Use Web Url Rewrites to no. All was fine before I switched and I wasn't getting that error above. Now I am. Any ideas? My .htaccess appears to be proper and my permissions on the folders on my server are various 644, 755, etc.

How do I resolve this issue?

EDIT: I am running my site on Ubuntu 14.0.4. LetsEncrypt used for my SSL. Green lock appears for frontend and admin area with no issues. Urls all work but include index.php. I am trying to remove that index.php from the urls for friendlier ones.

  • Did you configure your Server? Which server you are using? I guess apache. So you had to edit the vhost config files. Open yourdomain Did you see the SSL Sign? Unlocked or locked? – Michael H Feb 13 '17 at 4:28
  • My webserver (Ubuntu 14.04) has been configured properly for several months now running my Magento site live with no problems, only until now implementing LetsEncrypt CA. It worked, but requires index.php within my urls. I've tried all sorts of inserts recommended via Magento stack exchange, and keep receiving a 404 via port 443. No idea what I am missing. Site runs perfectly fine with Rewrites off, but I want friendly URLS without that index.php required. – Kristin Feb 14 '17 at 2:06
  • And having the Rewrites off...and event with it on, and getting the 404, there is a Green lock on both frontend and backend. So the CA was implemented correctly, just need the right settings for my .htaccess I think for my urls to work without the index.php – Kristin Feb 14 '17 at 2:08
0

To configure Magento to work with your SSL certificate, first you need to login to your admin area and go to System -> Configuration. enter image description here

Next, click on the Web link under the General tab in your left menu. enter image description here

Make sure that you've set the Use Secure URLs in Frontend and Use Secure URLs in Admin to yes. Doing this will make your Magento application work with SSL for those parts of your site. enter image description here

your Magento store is now configured to work over SSL!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.