1

Kindly help me on this error I get when I run this command:

enter image description here

The extension's composer.json:

{
"name": "veriteworks/m2-price",
"type": "magento2-module",
"license": [
    "OSL-3.0",
    "AFL-3.0"
],
"description": "Magento2 extension for Price.",
"version": "1.0.4",
"authors":[
    {
        "name": "Hirokazu Nishi",
        "email": "[email protected]",
        "homepage": "http://veriteworks.co.jp/",
        "role": "developer"
    }
],
"require": {
    "php": "~5.5.0|~5.6.0|~7.0.2",
    "magento/module-store": "~100.0",
    "magento/module-backend": "~100.0",
    "magento/module-media-storage": "~100.0",
    "magento/framework": "~100.0",
    "lib-libxml": "*"
},
"autoload": {
    "files": [
        "registration.php"
    ],
    "psr-4": {
        "Veriteworks\\Price\\": ""
    }
}

}

4
  • Did the vendor provide a private repository? The only module by this vendor listed on packagist.org is veriteworks/m2-japaneselocale Feb 13, 2017 at 2:52
  • @DannyNimmo According to the installation manual, I executed this command composer config repositories.veriteworksartifacts artifact ¥ /<Magento Installation Directory>/vendor/veriteworks/packages
    – Dean
    Feb 13, 2017 at 2:57
  • An artifact repository is simply a folder containing zip files. Assuming the vendor provided you with a zip, check that you're passing in the correct path to this folder. Feb 13, 2017 at 3:07
  • @DannyNimmo Now I know what is wrong. I-unzip the file. Thanks man!
    – Dean
    Feb 13, 2017 at 3:22

1 Answer 1

2

Posting my comments here as an answer.

Check that the module is listed on a public repository. If the vendor provided a private repository, check that this is accessible and configured correctly in your project's own composer.json.

In this case, the vendor provided instructions to use an artifact repository which is a folder on your local machine which should contain zip file packages of the module.

1
  • I had a similar problem, apparently I had 2 different magento.com accounts, and I was using user/pass on the one that did not have the package I was trying to install purchased! I switched the user/pass on ~/.composer/auth.json for repo.magento.com to the other one, and it worked.
    – Mac A.
    Jul 18, 2019 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.