1

I have installed docker for my local magento 2 development Following this stuff https://github.com/redbox-digital/magento-docker This currently best setup magento for linux container running docker. Hope team magento should port to linux soon Back to my question

I can go to docker container and run

composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition .

Yes i got all latest code version But when i run php bin/magento i got not found Cli
Could anyone tell me why it happens and how to fix it?
php -v show Cli 7.0.14 version

enter image description here

  • Is your Magento installation complete, can you run it from your browser? – Jonathan Ribas Feb 12 '17 at 16:46
  • No. I cant even run bin/magento. Got error descript above. Tried set permissions but not get any luck. It should be ok in order to setup install – mrtuvn Feb 12 '17 at 16:47
  • Try Magento cli install: devdocs.magento.com/guides/v2.1/install-gde/install/cli/… – Jonathan Ribas Feb 12 '17 at 16:50
  • Try to use /usr/local/php56/bin/php-cli bin/magento instade of php bin/magento. – Hardik Visa Feb 13 '17 at 5:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.