0

Ok so everything was fine and dandy on my machine yesterday, that is until I updated my magento to 1.9.3 and applied the security patch. Since then my images no longer show on the front or back end. The images are in the directories, they have the correct permissions. I have tried looking at some old fixes and none of these work or are irrelevant.

  • check the url of images, is they are populating correctly ? – Rajeev K Tomy Feb 10 '17 at 5:09
  • The image url looks fine but getting a 500 inernal server error when try to view directly and the images are in the directory when I search it out through ssh – user47507 Feb 10 '17 at 5:11
  • 500 internal server error : double check your media/ var/ folder permissions. They should be writable. – Rajeev K Tomy Feb 10 '17 at 5:14
  • both folders are writable. – user47507 Feb 10 '17 at 5:17
1

Ok so upon updating from Magento 1.9.2 to 1.9.3 Magento added a new .htaccess file to my media/ folder.

Old .htaccess file

#Options All -Indexes
<IfModule mod_php5.c>
php_flag engine 0
</IfModule>

AddHandler cgi-script .php .pl .py .jsp .asp .htm .shtml .sh .cgi
Options -ExecCGI

<IfModule mod_rewrite.c>

############################################
## enable rewrites

#    Options +FollowSymLinks
    RewriteEngine on

############################################
## never rewrite for existing files
RewriteCond %{REQUEST_FILENAME} !-f

############################################
## rewrite everything else to index.php

RewriteRule .* ../get.php [L]
</IfModule>

Since I already had my server Options set in my httpd.conf file the Options All -Indexes and the Options +FollowSymLinks needed to be commented out. The Options All -Indexes is only in the media/.htaccess file as far as I could tell from my update. My New .htaccess file

#Options All -Indexes
<IfModule mod_php5.c>
php_flag engine 0
</IfModule>

AddHandler cgi-script .php .pl .py .jsp .asp .htm .shtml .sh .cgi
Options -ExecCGI

<IfModule mod_rewrite.c>

############################################
## enable rewrites

#    Options +FollowSymLinks
    RewriteEngine on

############################################
## never rewrite for existing files
RewriteCond %{REQUEST_FILENAME} !-f

############################################
## rewrite everything else to index.php

RewriteRule .* ../get.php [L]
</IfModule>
  • Awesome! Thanks – Char Feb 17 '20 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy