3

I have updated magento version 2.1.3 to 2.1.4 via composer.

Its updated successfully without any error.Everything works perfectly ! except product catalog admin grid.

But after update 2.1.4 version i am unable to open product details from admin grid.

From Admin when i click on Products -> Catalog -> Its displays all the products in the grid -> but when i click on single product for edit details -> It shows blank.

Below is the screenshots :

enter image description here

On the console I have checked it shows below error :

_wasOpened is not defined

Below is the screenshot for error :

enter image description here

I have already done below steps but still error remains same :

  • rm -rf var/di var/generation
  • php bin/magento cache:flush
  • php bin/magento setup:upgrade
  • php bin/magento setup:static-content:deploy
  • php bin/magento setup:di:compile
  • php bin/magento indexer:reindex

Note : Its happened with all the grid ,unable to open detail view of cms pages as well..

3

The error you're getting comes from the app/code/Magento/Ui/view/base/web/templates/form/fieldset.html :

<div class="admin__fieldset-wrapper-content"
     css="'admin__collapsible-content': collapsible, '_show': opened, '_hide': !opened()">
    <fieldset
            if="opened() || _wasOpened"
            class="admin__fieldset"
            each="data: elems, as: 'element'" render=""/>
</div>

This _wasOpened property is supposed to be defined in app/code/Magento/Ui/view/base/web/js/form/components/fieldset.js :

    initConfig: function () {
        this._super();
        this._wasOpened = this.opened || !this.collapsible;

        return this;
    },

It's hard to say what's causing the issue, my guess is that there is a custom JS (extensions ?) that conflicts with the core JS because, as you can see from the GitHub history, there was no change to those two files between 2.1.3 and 2.1.4. So if I were you, I would start debugging in the JS file and see if the property declaration works properly and if it happens before the call in the HTML file.

UPDATE :

Main problem of here is browser cookies , Removed browser cookies and caching history and all manually or open link in private window(incognito) mode you will resolved your error

  • 1
    I've made several upgrades yesterday. An upgrade from 2.1.2 to 2.1.4 (a vanilla install without 3rd-party modules) works well. Even with a multistore setup and editing attributes with different values on each store view. (my 2 cents) – Barbanet Feb 8 '17 at 17:51
  • Problem with browser caching too !!! i have removed cookies and cache manually from browser and its resolved issue for the same – Manthan Dave Feb 9 '17 at 5:01
  • I have updated Magento version from M2 2.1.2 to M2 2.17 . After update i faced same problem but my problem is solved due this article. – Sourav Aug 16 '17 at 18:18
  • after browser cache and cookies delete problem is solved – Sourav Aug 16 '17 at 18:19
  • @Paarth Thanks , Good to know that you got solution from this :) – Manthan Dave Sep 19 '17 at 8:36
0

The problem is caused due to custom extension, which overlay default fieldset.js file. Custom extension is using old js content and now content is changed, so we got situation, when custom extension do not declare variable, but default template is using it.

Please see Ui components, which modify fieldset.js file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.