2

I am using Magento 1.13.1.0 and enable full page cache from admin. It seems the page speed is good but there is no files generated under /var/full_page_cache. I check the folder permission and its set to 777 , /var folder permission is also set to 777. If I remove this folder, Magento recreates this folder automatically, but no files are generated under this folder. Some of the folder is showing the usergroup as root:root while some of the folder shows apache:apache. full_page_cache folder is showing apache:apache as usergroup.

Any idea what could be the problem?

Thanks

  • Do you have memcached installed? – oleksii.svarychevskyi Feb 27 '14 at 16:44
  • It would be helpful to add your app/etc/config.xml (without your passwords!) to your question, so we can make sure you don't have problems in your config. – Tim Hofman Feb 27 '14 at 18:32
  • memcached is not installed – Pravin Feb 28 '14 at 6:37
  • content.screencast.com/users/p4pravin/folders/Default/media/… @Tim , here is the screenshot for app/etc/local.xml and I did not make any changes to app/etc/config.xml. – Pravin Feb 28 '14 at 6:50
  • Sorry, meant the local.xml indeed. Don't see any wrong things in your configuration regarding incorrect cache settings. There are many settings, but with this config it should just properly fall back to file. – Tim Hofman Feb 28 '14 at 9:17
1

Verify ownership for magento/var folder: chown -R apache:apache var

My guess is that due to permissions, Magento will fallback on using a system temporary dir created with sys_get_temp_dir(). I saw this happening few times, on my machine it was using private/var/tmp/magento/var/full_page_cache/.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.