0

We recently started working with Magento, and while we have found answer to a lot of issues we have had, this one is fairly tricky as I am not intimately familiar with the magento core. I am also not well versed in PHP.

Long story short:

We installed absolute them.

This was a green light after the cache was cleared.

We then made some changes to the theme as follows:

Switched the color of the background back, and forth.

Uploaded images

Configured UPS shipping

Configured a couple blocks

Reverted some configurations in an effort, (Of course clearing cache each time) And we are currently with the below StackTrace. Help is appreciated.

#1 /home/user/public_html/vendor/zendframework/zend-http/src/Headers.php(448): Zend\Http\Header\GenericHeader::fromString('X-Magento-Tags:...')
#2 /home/user/public_html/vendor/zendframework/zend-http/src/Headers.php(287): Zend\Http\Headers->lazyLoadHeader(9)
#3 /home/user/public_html/vendor/magento/framework/HTTP/PhpEnvironment/Response.php(31): Zend\Http\Headers->get('X-Magento-Tags')
#4 /home/user/public_html/var/generation/Magento/Framework/App/Response/Http/Interceptor.php(102): Magento\Framework\HTTP\PhpEnvironment\Response->getHeader('X-Magento-Tags')
#5 /home/user/public_html/vendor/magento/module-page-cache/Model/Controller/Result/BuiltinPlugin.php(83): Magento\Framework\App\Response\Http\Interceptor->getHeader('X-Magento-Tags')
#6 /home/user/public_html/vendor/magento/framework/Interception/Interceptor.php(142): Magento\PageCache\Model\Controller\Result\BuiltinPlugin->aroundRenderResult(Object(Magento\Framework\View\Result\Page\Interceptor), Object(Closure), Object(Magento\Framework\App\Response\Http\Interceptor))
#7 /home/user/public_html/var/generation/Magento/Framework/View/Result/Page/Interceptor.php(130): Magento\Framework\View\Result\Page\Interceptor->___callPlugins('renderResult', Array, Array)
#8 /home/user/public_html/vendor/magento/framework/App/Http.php(139): Magento\Framework\View\Result\Page\Interceptor->renderResult(Object(Magento\Framework\App\Response\Http\Interceptor))
#9 /home/user/public_html/vendor/magento/framework/App/Bootstrap.php(258): Magento\Framework\App\Http->launch()
#10 /home/user/public_html/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http))
#11 {main}";s:3:"url";s:1:"/";s:11:"script_name";s:10:"/index.php";}[root@srv1 report]#

EDIT

Alright so I ran the following due to the update today

composer require magento/product-community-edition 2.1.4 --no-update
composer update
rm -rf var/di var/generation
php bin/magento cache:flush
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento indexer:reindex

now I have the stack trace

#0 /home/user/public_html/vendor/magento/framework/Encryption/Crypt.php(54): Magento\Framework\App\ErrorHandler->handler(8192, 'Function mcrypt...', '/home/user/...', 54, Array)
#1 /home/user/public_html/vendor/magento/framework/Encryption/Encryptor.php(401): Magento\Framework\Encryption\Crypt->__construct('9475d949bdedede...', 'rijndael-256', 'cbc', 'nVcS2cCxAdQxJxe...')
#2 /home/user/public_html/vendor/magento/framework/Encryption/Encryptor.php(313): Magento\Framework\Encryption\Encryptor->getCrypt('9475d949bdedede...', 2, 'nVcS2cCxAdQxJxe...')
#3 /home/user/public_html/vendor/magento/module-config/Model/Config/Backend/Encrypted.php(109): Magento\Framework\Encryption\Encryptor->decrypt('a4AUV+R670BBjY8...')
#4 /home/user/public_html/var/generation/Magento/Config/Model/Config/Backend/Encrypted/Interceptor.php(37): Magento\Config\Model\Config\Backend\Encrypted->processValue('0:2:nVcS2cCxAdQ...')
#5 /home/user/public_html/vendor/magento/framework/App/Config/MetadataConfigTypeProcessor.php(88): Magento\Config\Model\Config\Backend\Encrypted\Interceptor->processValue('0:2:nVcS2cCxAdQ...')
#6 /home/user/public_html/vendor/magento/framework/App/Config/MetadataConfigTypeProcessor.php(106): Magento\Framework\App\Config\MetadataConfigTypeProcessor->processScopeData(Array)
#7 /home/user/public_html/vendor/magento/framework/App/Config/PostProcessorComposite.php(34): Magento\Framework\App\Config\MetadataConfigTypeProcessor->process(Array)
#8 /home/user/public_html/var/generation/Magento/Framework/App/Config/PostProcessorComposite/Proxy.php(95): Magento\Framework\App\Config\PostProcessorComposite->process(Array)
#9 /home/user/public_html/vendor/magento/module-config/App/Config/Type/System.php(102): Magento\Framework\App\Config\PostProcessorComposite\Proxy->process(Array)
#10 /home/user/public_html/vendor/magento/framework/App/Config.php(139): Magento\Config\App\Config\Type\System->get('default/web/sec...')
#11 /home/user/public_html/vendor/magento/framework/App/Config.php(90): Magento\Framework\App\Config->get('system', 'default/web/sec...')
#12 /home/user/public_html/vendor/magento/framework/App/Config.php(103): Magento\Framework\App\Config->getValue('web/secure/use_...', 'default', NULL)
#13 /home/user/public_html/vendor/magento/module-store/Model/HeaderProvider/Hsts.php(48): Magento\Framework\App\Config->isSetFlag('web/secure/use_...')
#14 /home/user/public_html/vendor/magento/framework/App/Response/HeaderManager.php(41): Magento\Store\Model\HeaderProvider\Hsts->canApply()
#15 /home/user/public_html/vendor/magento/framework/Interception/Interceptor.php(123): Magento\Framework\App\Response\HeaderManager->beforeSendResponse(Object(Magento\Framework\App\Response\Http\Interceptor))
#16 /home/user/public_html/var/generation/Magento/Framework/App/Response/Http/Interceptor.php(117): Magento\Framework\App\Response\Http\Interceptor->___callPlugins('sendResponse', Array, Array)
#17 /home/user/public_html/pub/errors/report.php(15): Magento\Framework\App\Response\Http\Interceptor->sendResponse()
#18 /home/user/public_html/vendor/magento/framework/App/Http.php(324): require('/home/user/...')
#19 /home/user/public_html/vendor/magento/framework/App/Http.php(160): Magento\Framework\App\Http->handleGenericReport(Object(Magento\Framework\App\Bootstrap), Object(Exception))
#20 /home/user/public_html/vendor/magento/framework/App/Bootstrap.php(263): Magento\Framework\App\Http->catchException(Object(Magento\Framework\App\Bootstrap), Object(Exception))
#21 /home/user/public_html/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http))
#22 {main} [] []
[2017-02-08 17:50:53] main.CRITICAL: Exception: Deprecated Functionality: Function mcrypt_module_open() is deprecated in /home/user/public_html/vendor/magento/framework/Encryption/Crypt.php on line 54 in /home/user/public_html/vendor/magento/framework/App/ErrorHandler.php:61
Stack trace:
#0 /home/user/public_html/vendor/magento/framework/Encryption/Crypt.php(54): Magento\Framework\App\ErrorHandler->handler(8192, 'Function mcrypt...', '/home/user/...', 54, Array)
#1 /home/user/public_html/vendor/magento/framework/Encryption/Encryptor.php(401): Magento\Framework\Encryption\Crypt->__construct('9475d949bdedede...', 'rijndael-256', 'cbc', 'nVcS2cCxAdQxJxe...')
#2 /home/user/public_html/vendor/magento/framework/Encryption/Encryptor.php(313): Magento\Framework\Encryption\Encryptor->getCrypt('9475d949bdedede...', 2, 'nVcS2cCxAdQxJxe...')
#3 /home/user/public_html/vendor/magento/module-config/Model/Config/Backend/Encrypted.php(109): Magento\Framework\Encryption\Encryptor->decrypt('a4AUV+R670BBjY8...')
#4 /home/user/public_html/var/generation/Magento/Config/Model/Config/Backend/Encrypted/Interceptor.php(37): Magento\Config\Model\Config\Backend\Encrypted->processValue('0:2:nVcS2cCxAdQ...')
#5 /home/user/public_html/vendor/magento/framework/App/Config/MetadataConfigTypeProcessor.php(88): Magento\Config\Model\Config\Backend\Encrypted\Interceptor->processValue('0:2:nVcS2cCxAdQ...')
#6 /home/user/public_html/vendor/magento/framework/App/Config/MetadataConfigTypeProcessor.php(106): Magento\Framework\App\Config\MetadataConfigTypeProcessor->processScopeData(Array)
#7 /home/user/public_html/vendor/magento/framework/App/Config/PostProcessorComposite.php(34): Magento\Framework\App\Config\MetadataConfigTypeProcessor->process(Array)
#8 /home/user/public_html/var/generation/Magento/Framework/App/Config/PostProcessorComposite/Proxy.php(95): Magento\Framework\App\Config\PostProcessorComposite->process(Array)
#9 /home/user/public_html/vendor/magento/module-config/App/Config/Type/System.php(102): Magento\Framework\App\Config\PostProcessorComposite\Proxy->process(Array)
#10 /home/user/public_html/vendor/magento/framework/App/Config.php(139): Magento\Config\App\Config\Type\System->get('default/web/sec...')
#11 /home/user/public_html/vendor/magento/framework/App/Config.php(90): Magento\Framework\App\Config->get('system', 'default/web/sec...')
#12 /home/user/public_html/vendor/magento/framework/App/Config.php(103): Magento\Framework\App\Config->getValue('web/secure/use_...', 'default', NULL)
#13 /home/user/public_html/vendor/magento/module-store/Model/HeaderProvider/Hsts.php(48): Magento\Framework\App\Config->isSetFlag('web/secure/use_...')
#14 /home/user/public_html/vendor/magento/framework/App/Response/HeaderManager.php(41): Magento\Store\Model\HeaderProvider\Hsts->canApply()
#15 /home/user/public_html/vendor/magento/framework/Interception/Interceptor.php(123): Magento\Framework\App\Response\HeaderManager->beforeSendResponse(Object(Magento\Framework\App\Response\Http\Interceptor))
#16 /home/user/public_html/var/generation/Magento/Framework/App/Response/Http/Interceptor.php(117): Magento\Framework\App\Response\Http\Interceptor->___callPlugins('sendResponse', Array, Array)
#17 /home/user/public_html/pub/errors/report.php(15): Magento\Framework\App\Response\Http\Interceptor->sendResponse()
#18 /home/user/public_html/vendor/magento/framework/App/Http.php(324): require('/home/user/...')
#19 /home/user/public_html/vendor/magento/framework/App/Http.php(160): Magento\Framework\App\Http->handleGenericReport(Object(Magento\Framework\App\Bootstrap), Object(Exception))
#20 /home/user/public_html/vendor/magento/framework/App/Bootstrap.php(263): Magento\Framework\App\Http->catchException(Object(Magento\Framework\App\Bootstrap), Object(Exception))
#21 /home/user/public_html/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http))
#22 {main} [] []

UPDATE

So end of day switched back to PHP 5.6 for MCrypt deprecation issue.

Back to original problem if anyone idea reply me.

  • Remove var folder and try to run static content command rebuild it. – Nits Feb 7 '17 at 4:49
  • @Nits So I moved my var/ folder to varBACK/ then ran bin/magento setup:static-content:deploy Unfortunately still same error – shwm19 Feb 7 '17 at 5:36
  • If there is additional information that anyone would need, please do not hesitate to ask. It is a VPS and I have full root access. – shwm19 Feb 8 '17 at 4:11
0

A theme is an aggregation of many modules and these can amount to a substantial amount of complex codes to maintain.

--> taking a theme in your Magento system is like adding a software on top of something complex (that is Magento).. the sum is likely not trivial

--> your post dates back 1 year ago and Magento has evolved a lot since but your post highlights that theme is good value to purchase but can give big learning curve

My take on this is hopefully a solution for you: if really you want to make use of a theme, then make it an investment. By this, I mean study this set of modules and be ready for maintaining it going forward.

Now, with Magento 2 evolving much faster than in the past, it is possible that using a theme may consist in using some partners you have already who build themes so that you can reliably have support going forward

0

SO if anyone has a real solution, I'd be interested. What I ended up doing was removing the absolute theme and restoring a backup I took BEFORE installing the theme (Like a good server admin). If you can't fix it, rollback.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.