3

I have a jay.css file in directory /public_html/skin/frontend/neighborhood/default/css but Magento is not recognizing the file changes.

I have cloudflare and cleared the cache but it still doesn't load the updated jay.css

I deleted the jay.css file, went to the url and it still loaded the jay.css so it must be stored somewhere in cache but don't know where.

I went to var/cache and deleted all the folders, i've flushed Magento Cache and also flushed cached storage.

I added a jay1.css file to the same directory to see if it would load and when I type in the url it didn't load it.

I've also restarted my apache server and nothing seems to work. My jay.css doesn't up.

  • css merging enable in your site ?? – Murtuza Zabuawala Feb 7 '17 at 4:08
  • Temporary disable cache and cloudflare or cdn settings and check. – Nits Feb 7 '17 at 4:43
  • Have you removed var/view_processed/ – Dava Gordon Aug 31 at 22:04
0

It may be stored in your browsers Cache not Magento's. If you're using Chrome click top right 3 bars for settings and go to history "clear cache".

Also if you only deleted the jay.css in your local files and not remote files it will still be there make sure you cleared it from both.

The most common error I see with problems like this is just a problem with the url and the programmer types in the wrong file path.

  • I've cleared my browsers cache and it still not loading the updated jay.css – altoids Feb 6 '17 at 19:37
0

First check if your css is loaded, your website -> right click and select view page source or just press ctrl+u. There you'll find your jay.css file. Check if it is showing jay.css and the right url. Click on it, see if it is loading ok.

It should look like this:

<link rel="stylesheet" type="text/css" href="http://www.exemple.com/skin/frontend/neighborhood/default/css/jay.css" media="all" />

For this problem to happen, There are three reasons I know of:

1.) There might be an issue because of System Cache. Clean the cache from the backend or go to magentoroot/var/ and delete the contents of the cache and session folder.

2.) There can be issue with the file permission of your css File. In this case just type the following command in terminal, sudo chmod 777 -R /magentoroot/

3.) Lastly, there could be something wrong with the url in your core_config_data table of your database, which I think you have already checked.

0

This is not an issue This is the behavior of cloudflare or any cdn .

for this kind of issue cloudflare and other cdn providers provides you facility of purging

In cloudflare , login to clodflare

go to caching click on purge individual files

and then insert path to you css with in that

ex : http://yourSite/skin/frontend/neighborhood/default/css/jay.css

and then click on purge individual files and your file would be updated

0

It might happens due to cache problem.

  1. First clear your cache then reload.
  2. If not succeed then use the shortcut to refresh ctrl+f5
  • This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. - From Review – Murtuza Zabuawala Feb 7 '17 at 5:49
  • @MurtuzaZabuawala I think it's an answer. We don't need to take care about the technical here. – Khoa TruongDinh Feb 7 '17 at 6:13
  • @KhoaTruongDinh may be you right but he should ask to OP , that he has tried those are things and OP has already written all this steps in the question so that's why I think that this should be not an answer – Murtuza Zabuawala Feb 7 '17 at 6:16
  • i just wanna help. I use this way for that problem. if my answer really distrubing you, im sorry. @MurtuzaZabuawala – syahidah humairoh Feb 7 '17 at 7:23
  • @syahidahhumairoh no buddy , here we are to improve every one knowledge and if anyone is wrong then we just tell him/her you wrong with this point and we also take care not to avoid spam answer and low quality answers. – Murtuza Zabuawala Feb 7 '17 at 7:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.