Using Magmi v.0.7.21 to upload images to products in Magento 1.7. I am having some issues while uploading new images to products that already has some images.

The issue is that, when I upload new images with new base image set, the old base image gets deleted. The behaviour I expect is to change the base image flag and keep the old base image in the gallery instead of completely removing the old image.

I am new to Magmi and I'm not sure what details are needed to figure out this issue. I can update the question if someone asks me for more specific details. Any help is much appreciated.


Magento can not have 2 base images. A possible solution here is update the "base image" with new image. Give path(generally media/import/imagename.jpg) in your case it should be directly "/imagename.jpg" in "base_image" field of your csv file, If you have already uploaded images in media/import folder. And add "media_gallery" field in your csv file. Assign multiple and previous base image in this field. for e.g. "/oldimage.jpg;/newmultipleimages.jpg;/newmoreimages.jpg" it will add new base image and keep your old image as well. it will actually add new images instead of replacing it with old ones and also assign multiple images for a product.

Let me know if you have any doubts. I hope this might help you.

| improve this answer | |
  • I have already tried your suggestion. In the csv I uploaded, I put "+/newbaseimage.jpg" in base_image field and in media_gallery field, I added "+/oldbaseimage.jpg::image_label;+/othernewimage1.jpg::label1;+/othernewimage2.jpg::label2...". Also tried putting the full directory path of the old base image(the magento path where the image is actually present). I got same result both times. The old image is removed from gallery. What I have left to try is to actually copy the original image to magmi import folder and run the import. – anupsabraham Mar 19 '17 at 17:38
  • yes. please do that because by default in magmi setting it takes images from media/import folder you can change path as well. path should start from "/" then folder name in case of not getting images updated. for e.g. "/media/import/newimagename.jpg". – RUSHABH SHAH Mar 29 '17 at 10:11
  • @3CE your problem will be solved with this suggestion. you might have forgot to put forward slash in image path. Also make sure you have turned on Image attribute Processor extension. – RUSHABH SHAH Mar 29 '17 at 10:14
  • Yeah. That sounds about right. But having to copy the original file to import directory just to add a new image sounds like an awful lot of work. I think there should be an option in Magmi to deal with this kind of situation. – anupsabraham Mar 29 '17 at 11:30
  • @anupsabraham There is a solution you can change path in magmi to your directory as well in image attribute processor plugin. – RUSHABH SHAH Mar 29 '17 at 12:18

I faced kinda issue. My problem was when i update base image, i can see the updated image on backend page but i didn't on front site. I don't know what caused this issue. btw i just compared the updated product with not updated product.

If you have multiple store views, you have to set the title on specific store view. I think it's a bug for Magmi.

| improve this answer | |
  • In my case there is only one store. And the old base image is removed from admin as well as the gallery. – anupsabraham Mar 28 '17 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.