1

I have a problem with uploading new extension version to the Magento Marketplace. The error message is Php require section in composer is empty My composer.json file hasn't been changed (since previous approved versions on Marketplace) and it contains only one dependency:

"require": {
  "magento/module-catalog": "~101.0.*"
}

I tried to add php dependency (tried different versions), but that doesn't help, error message remains the same.

Can't figure out what is wrong here? Have anyone experienced this issue on Marketplace?

2

"php require section" sounds like you need to require a PHP version now. For example to require any PHP 5.6 or 7.0 version:

"require": {
  "php": "^5.6 || ^7.0",
  "magento/module-catalog": "~101.0.*"
}
| improve this answer | |
  • Sorry, this trailing comma is not present in the composer.json archive. I have added require "php": "~7.0.*", and seems like it works now (doesn't work if I put php dependency AFTER catalog dependency). – m2lover Feb 4 '17 at 11:32
  • But now Marketplace shows me another error "Can not read the archive" :) ... and I love it! – m2lover Feb 4 '17 at 11:33
  • OK great, I removed the part about the syntax from my answer as well – Fabian Schmengler Feb 4 '17 at 11:33
  • Why double || ? and not single | ? – Mr.K Feb 4 '17 at 11:50
  • @Mr.K that's what the official composer documentation says: getcomposer.org/doc/articles/versions.md#range But both seem to work – Fabian Schmengler Feb 4 '17 at 12:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.