0

I was having a configuration where the setup was like below

Main Website
     ---->Store 1(store for XYZ sister company)
          ----> English Store View
     ---->Store 2(store for ABC sister company)
          ----> English Store View
     ---->Store 3(store for LMN sister company)
          ----> English Store View

And I have a custom theme, which is getting applied properly for all the store views.

But, recently, my client wanted three other store views for each store. Namely, german, french and dutch. Accordingly I created the store views and my current setup looks like this:

Main Website
     ---->Store 1(store for XYZ sister company)
          ----> English Store View
          ----> German Store View
          ----> French Store View
          ----> Dutch Store View
     ---->Store 2(store for ABC sister company)
          ----> English Store View
          ----> German Store View
          ----> French Store View
          ----> Dutch Store View
     ---->Store 3(store for LMN sister company)
          ----> English Store View
          ----> German Store View
          ----> French Store View
          ----> Dutch Store View

The custom theme is getting applied only for the english store view, but not the other ones. i.e., for german, french and dutch store views.

I have already checked in System->Configuration->Web , System->Configuration->General and System->Configuration->Design for the working ones as well as the non working ones, both are looking same.

Further, when I investigated, The template i,e., all the phtml files were being pulled from rwd/default instead of rwd/custom_theme, (custom_theme is the theme which I am using).

I tried adding the template path rwd/custom_theme for Templates, Skin (Images / CSS) and Layout in System->Configuration->Design for the german storeview of XYZ company. The page loads with no js and css. And the template i,e., all the phtml files were loaded from base/default, this time.

So I renamed the rwd/default to rwd/default_old and Copied rwd/custom_theme to rwd/default. And It started working. I am sure this is not the right way to do this.

Your help is highly appreciated, and thanks in advance.

0

Finally got it working, By going to System->Design and "Add Design Change"(setting the rwd/custom_theme) to all the store views that I had created newly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.