6

I am trying to import csv in Magento 2. There are no errors given by Magento while importing, but column additional_attributes is totally ignored and additional_images is ignored if it contains multiple values. I used following import options:

Field divider: ,

Value divider: |

Fields enclosure: active

The csv looks like, this:

sku,additional_attributes,additional_images
123,"manufacturer=ABC,material=Wood|Metal,color=red","2.png,3.png"

Why are those values getting ignored?

Edit: If I deactivate the fields enclosure checkfield I receive the following error:

1. Value for 'manufacturer' attribute contains incorrect value, see acceptable values on settings specified for Admin in row(s): 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 1

The values equals exactly the value specified for that attribute in the backend.

SOLUTION: I replaced al the | with a , in my csv except for the additional_attributes column. During the import I used the default configuration, both delimiters as , field enclosure checkbox unchecked. Now it is working.

  • 1
    Please post your solution as an answer and accept it. Otherwise this question looks as if it were still open. – Andreas von Studnitz Feb 3 '17 at 19:32
5

SOLUTION: I replaced all the | with a , in my csv except for the additional_attributes column. During the import I used the default configuration, both delimiters as , and field enclosure checkbox unchecked. Now it is working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.