4

I have including of phtml file in cms page (home page) {{block type="catalog/product_new" product_ids="6747,4652,605,571,518,182,4432,4425" template="catalog/product/home_slider.phtml" }}, and I need no-caching this phtml file. How to disable cache for this?

{block type="catalog/product_new" product_ids="6747,4652,605,571,518,182,4432,4425" template="catalog/product/home_slider.phtml" cache_lifetime="null"}}  - not working
4

add cache_lifetime="null" to every inclusion of this block.

for example if you add block in CMS content:

{{block type="cms/block" block_id="your_block_id" cache_lifetime="null"}} 

or if you add block in XML:

<block type="cms/block" name="cms_footer_links" before="footer_links">
     <action method="setBlockId"><block_id>footer_links_company</block_id></action>
     <action method="setCacheLifetime"><lifetime>null</lifetime></action>
</block>
  • I include this block in my cms/page, I'm sorry, but I saw that is no cms statick block ---- {{block type="catalog/product_new" template="catalog/product/home_slider.phtml"}} and when I'm add cache_lifetime="null" in declaration {{block type="catalog/product_new" template="catalog/product/home_slider.phtml" cache_lifetime="null"}} , my block is not working – Sklerozz Jan 30 '17 at 10:18
2

What Magento are u using? 1, 2? CE, EE? Any modules for caching?

EDIT:

I see. It should work:
how to disable cache for a CMS page?
how to disable cache for cms block?

  • Magento Version 1.8.1.0, CE, without any modules for caching – Sklerozz Jan 30 '17 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.