1

Magento 2 latest version currently will not load any grid in the admin, there is no errors in the console whatsoever. The requests via Ajax are not even firing.

However I have installed my custom module which holds its own grid which works perfectly fine :( confused!

I've tried disabling/removing my module from the code and still doesn't work. I'm running out of options.

Hopefully someone can shed some light on the issue. I believe this is happening for a lot of people however none of there issues related to the same as mine.

0

It sounds like your module uses etc/adminhtml/di.xml to add your data provider. This is a problem because magento uses etc/di.xml to declare it's data provider collection and it gets overriden by the more specific adminhtml collection.

You need to add your data provider in etc/di.xml instead.

1
  • If anyone is experiencing this issue then this is the problem, great work Aaron.
    – TheOnlyOne
    Jan 26 '17 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.