0

I added a module by these command

php bin/magento module:status
php bin/magento module:enable module

Everything was fine then I run this

php bin/magento setup:upgrade

After this everything messed up, The output of this command is

php bin/magento setup:upgrade
Cache cleared successfully
File system cleanup:
/home/xyz/public_html/var/generation/Composer
/home/xyz/public_html/var/generation/Magento
/home/xyz/public_html/var/generation/Symfony
The directory '/home/xyz/public_html/var/di/' doesn't exist - skipping cleanup
Updating modules:
Schema creation/updates:

And after the execution of this command My site returning HTTP ERROR 500.

Any Idea how to solve this ??

2

Enable the developer mode. By running the below commend.

php bin/magento deploy:mode:set developer

after that you can see the errors trace in frontend.

0

For the unexpected 500 error, we should enable error reporting on the bootstrap. Should enable error reporting with -1 value. That will report all PHP errors.

app/bootstrap.php

ini_set('display_errors', -1) // Should enable error reporting with -1 value.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.