2

I have a Magento EE 1.13.02 website. One of the attributes in my layered navigation is one that filters down on shoe size. Inside of my attribute, I have shoe sizes ranging from size 6 to size 15.

My issue is, when the page loads, my attributes load as follows:

10,11,12,13,14,15,6,7,8,9

instead of

6,7,8,9,10,11,12,13,14,15

I thought I could just set the positioning for each attribute and reindex but it doesn't solve the issue.

Any ideas on causes or possible fixes?

0
2

When you go to the screen where you can edit attribute option there is "position" field as well fill those fields in order and in frontend they will appear as you require.

4
  • If you are talking about the Attribute > Manage Label / Options, I only have Admin, Storeview and Position as options to fill in. – Tom Feb 24 '14 at 17:51
  • Yes the "position". - I've edited the answer. – Subesh Pokhrel Feb 24 '14 at 17:56
  • Okay then, I already placed values in the position field. I did re-index but perhaps it didn't index the product attributes. – Tom Feb 24 '14 at 18:00
  • This will fix your issue. Go to your "shoe size" attribute -> manage labels -> add position values (just needs to be in order) to your sizes, 6-15. – musicliftsme Feb 24 '14 at 20:08
2

In the Magento Admin Panel:

  1. go to Catalog > Manage Attributes
  2. Edit the "shoe_size" attribute you have created
  3. Click on the left navigation where it says "Manage Label/Options"
  4. Next to each Shoe Size Option you will have a position column. Starting with 0, number each size's position in your desired order. So for example: make size 6 - have 0 for position, size 7 have 1 for position and so on...
  5. Then save. It should be reflected in the sorting on both the left navigation as well as in the product drop down for Shoe Size on the frontend/backend.

Not the answer you're looking for? Browse other questions tagged or ask your own question.