0

I have tried everything I found in the different post related to this.

I already review:

• The magento setting is correct.
• That the rewrite module is enabled.
• The rules and conditions in it .htaccess.

But magento keeps sending me the 404 error every time I try to navigate, only the home page works.

This is the Magento Config

Go to System > Configuration > Web > Search Engine Optimization

Use Web Server Rewrites: YES
And the Unsecure and Secure too.

This is the configuration on my .htaccess

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

Is there anything else I should do?


1

Follow the simple steps below

1) Change a Setting in the Admin section.

The first thing you need to do is to log in to your Magento admin panel (index.php/admin) to change a very simple setting which will let Magento know that you intend to use URL rewriting throughout your store rather than their ugly default URLs.

Login, and change the following setting:

Go to System > Configuration > Web > Search Engine Optimization

Use Web Server Rewrites: YES

That was easy, wasn’t it? Okay, now for the final step.

2) Use a .htaccess File to rewrite the URLs

The final step involves creating a .htaccess file in the Magento installation folder in order to compliment the settings you have changed within your admin settings earlier, and this will actually rewrite the URLs. Choose the applicable .htaccess version below.

If your Magento store is installed in root (public_html), use this:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

If your Magento store is installed in a subfolder (public_html/shop), use this:

RewriteEngine On
RewriteBase /shop/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /shop/index.php [L]
| improve this answer | |
0

This Work for me: If somebody needs the answer

I put the configuration from the .htacces file on my vhost.conf on apache

<Directory /var/www/magento/>
   <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteBase /
      RewriteRule ^index\.php$ - [L]
      RewriteCond %{REQUEST_FILENAME} !-f
      RewriteCond %{REQUEST_FILENAME} !-d
      RewriteRule . /index.php [L]
   </IfModule>
</Directory>
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.