5
Use Secure URLs on Storefront = Yes

Use Secure URLs in Admin = Yes

Secure Base URL = starts with HTTPS

Why does my sitemap not start each link with https?

1

https://github.com/magento/magento2/issues/8644 shows this issue to have been fixed in versions 2.1.9 and 2.2.0. The workaround below appears to work if you're unable to update your store.


Update the Base URL of the store you are generating the sitemap for.

From the admin dashboard:

  1. Go to Stores > Settings > Configuration
  2. Expand General and select Web
  3. If you have multiple stores, confirm you are updating the correct store by referencing the scope switcher at the top left of the page.
  4. Expand Base URLs
  5. Update the protocol used in Base URL from http:// to https://
  6. Click Save Config and clear cache
  7. Generate the sitemap and confirm URL's have been updated.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.