2

I'm user of Magento and out website is supported by web hosting company, simplehelix.

I want to extend our website session time because the remaining time of login is too short. I already set the time on Magento back-end server but it didn't work. I saw this phase like

Magento will rely on session.gc_maxlifetime, despite what you've set in the store admin area.

So i tried to update php.ini or htacess file but htacess file doesn't have gc_maxlifetime value. I found the php.ini file but it was an back-up file. So i create own php.ini file and modify the gc_maxlifetime to 10800(about 3 hrs).However, i'm facing on the same situation.

By searching on Google, lots of programmers said that when setting on php.ini is changed, The restart of server is needed. So could i ask the web hosting company or is there any other way to apply this new set up? Thank you so much.

2
  • It works ! If you have an issue like that, Try it ! – 3CE Jan 24 '17 at 22:45
  • 1
    Solution for beginner - In order to access these file, you need linux server like putty. Go login and write code like "cd /usr/local/lib/php.ini." on command. And you can edit the codes with vim or vi. So you should chage the gc_maxlifetime value. Not use back-up file. Because already exsit php.ini file on your web server. Thank you ! – 3CE Jan 26 '17 at 14:15
0

Easiest thing you can do is configure session timeout value from the backend. For Magento 2,

Stores->Configuration->Advanced->Admin->Security

and find the entry named Admin Session Lifetime (seconds) and untick the checkbox then you can enter custom value. Insert time period you want to automatically locked in seconds (Ex-3600 for one hour) and click Save Config

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.