3

I installed an existing Magento installation on a clean CentOS server. This installation was running fast, with no problems and without any caching module.

Now, suddenly over the weekend, the speed dropped down from 2s/page to 5s/page.

Where do i have to look for a reason?

Update: I cleared the Magento cache folder, and now it's running fast again. How to avoid this in the future?

  • what cache backend do you use, and did you clean the cache after install the module? – Flyingmana Feb 25 '14 at 16:27
1

If you are running Magento 1.8+ I highly recommend you enabled REDIS cache (See KB article here)

Here is some great information on speeding up Magento, implement the features that apply: http://www.magentocommerce.com/boards/viewthread/36225/

Finally look into optimizing your database using mysqltuner.pl and tuning-primer.sh Google these and run against your database, follow the recommendations.

You should also configure your store to periodically clean the visitor logs:

System > Configuration > Advanced > System > Log Cleaning

Personal note: I too experienced the same performance drop, implementing a lot of the above helped significantly. You need to keep monitoring your sites performance and adjust settings as necessary.

Good luck!

  • I installed APC in the meanwhile. Pageload is now within 2 seconds, so that's good. I also viewed mysqltuner.pl, the only recommendation was to enable slow query log and i see some error: ERROR 2013 (HY000) at line 1: Lost connection to MySQL server during query?? Yesterday, suddenly my entire system went down for some reason. I had to restart the system. Now i'm looking for a reason in the logs, but i can't find anything... – Royw Feb 26 '14 at 9:04
  • If you are able to access via CLI use the linux top command to find any high CPU/Memory processes. – B00MER Feb 26 '14 at 10:29
  • In my hosting graphs, i see a high CPU peek around the time that the system went down... At this time, there are no high CPU processes. – Royw Feb 26 '14 at 11:49
  • I still advise that you go with REDIS, sub-zero page load times are hard to beat. If you have questions about another issue, please feel free to post a new question as it is not related to this one. If I have resolved your issue, kindly mark my answer as the accepted solution. SR – SR_Magento Feb 26 '14 at 12:10
2

dont use file based caching. this causes many i/o requests which could slow down your application.

  • thats nothing a cache clean would fix, as many files on disk dont slow down the cache read magically. – Flyingmana Feb 25 '14 at 16:26
0

Where do i have to look for a reason?

This is a bit old but I just had the same problem with v2.2.7 with a default setup (no REDIS or special mysql optimizations). I've been testing it fine for a few weeks or more and it's been pretty fast. Yesterday, out of nowhere, it got crazy slow.

When i looked at System > Tools > Cache Management everything was disabled. I'm not sure how that happened. It's been enabled since install. The only thing I did that day was try to apply a patch (unsuccessfully) but there were no warning or error messages in the console saying cache would be disabled. After re-enabling cache, everything was fast again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.