3

I am trying to install magento2 on shared hosting environment this is what i did.

  1. Downloaded magento .zip archive and uploaded it to server in public_html/magento2 directory.

Tried running it in browser it gives me this error "Vendor autoload is not found. Please run 'composer install' under application root directory."

Same archive is working fine in my local server, i have successfully installed it on local server with sample data.

Please guide me what i am doing wrong.

EDIT

I have SSH access of my shared hosting, as i am on windows so i have connected that via putty and when i run composer install there it gives me this error "-bash: composer: command not found"

  • 1
    Composer must be install on your hosting. Please check there is composer installed or not. – Suresh Chikani Jan 23 '17 at 13:05
  • Well, how do i check that, if that is installed or not.? I have SSH access of my shared hosting, now when i run "composer install" there via ssh it gives me this error "-bash: composer: command not found" – Soeb Safi Jan 24 '17 at 6:51
  • You have to first install composer on server. – Suresh Chikani Jan 24 '17 at 6:54
  • Shared hosing environments does allow anything to be installed, they will directly point me towards VPS or dedicated server. – Soeb Safi Jan 24 '17 at 6:55
  • It must be composer install otherwise you can't setup magento-2. – Suresh Chikani Jan 24 '17 at 6:58
3

You can just download composer in Magento root directory and run it like php composer.phar install or download all locally, run composer install and upload vendor directory on the server.

  • I am on shared hosting, and i had a talk with my hosting company they are ready to install composer for me, but they are asking me where they actually install it, shall i ask them to install in in public_html/composer Please guide me where to install composer if i want to use magento. – Soeb Safi Jan 24 '17 at 10:59
  • composer is just php script (in phar format). You can place it in any folder. when run, just use full path to it, like php progect/root/composer.phar install – KAndy Jan 24 '17 at 11:44
  • my hosting company has installed composer for me in root directory, but still, when I run php composer.phar install it says that the extension is not enabled. – Soeb Safi Jan 27 '17 at 8:13
  • Can you provide error? – KAndy Jan 27 '17 at 12:31
2

You have to install it to your localhost, and then transfer files into your shared web server. That worked for me.

0

You need to use SSH to connect to your host IP and when logged in, run the following commands to install composer;

curl -sS https://getcomposer.org/installer | php

mv composer.phar /usr/local/bin/composer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.