1

What i have done:

  • Fresh install of Magento 2.1.3
  • [Github] firegento-magesetup2; firegento/firegento-magesetup2
  • [Github] german language files; splendidinternet/Magento2_German_LocalePack_de_DE

My question is: When i change the logo under content - configuration - edit (single shop configuration) - header nothing changes in the frontend.

Any suggestion for this issue?

1
  • Did you clear Magento Cache? Commented Jan 21, 2017 at 5:32

3 Answers 3

2

Step to change logo:

  1. Go to Content->Configuration and click on EDIT (desired store)
  2. Go to 'Header' under "Other Settings" section of page.
  3. Upload the logo in this.

I added image for reference. Please check if it helps you. enter image description here

Update: You can also do adding logo image in theme/default.xml file. Upload logo image in images directory of your theme and specify name in default.xml file.

<body>
    <referenceBlock name="logo">
        <arguments>
            <argument name="logo_file" xsi:type="string">images/logo_new.png</argument>
            <argument name="logo_img_width" xsi:type="number">300</argument>
            <argument name="logo_img_height" xsi:type="number">300</argument>
        </arguments>
    </referenceBlock>
</body>

Here you can also define height and width. Images directory path YOUR_THEME/web/

3
  • Hi, this is exactly what i did in the admin panel. Commented Jan 21, 2017 at 10:59
  • But i found out that no edits under "other settings" take effect to the frontend. Of course with clearing the cache. In my installation i dont have any folders under /app/design/frontend/Magento/. All theme files are located in vendor/magento/theme-frontend-luma/. Can this be the reason why all my settings are not applied? I also tried magento setup:static-content:deploy. No success... Commented Jan 21, 2017 at 11:08
  • [1] Under 'Other setting' you will to click on header to view this setting. [2] If you are not using custom theme then there will be nothing under /app/design/frontend and only Magento directory, that's default. [3] No this is not reason and you are editing core theme files of luma theme vendor/magento/theme-frontend-luma/. You need to extend these files. Editing core files are not recommended.
    – Jarnail S
    Commented Jan 23, 2017 at 3:54
2

For all who have the same problem: It does not work in single shop mode and i couldnt solve it (Magento 2.1.3). After adding a new store and a new storeview the settings have been accepted.

0

Another way to do this is to head down to your logo.phtml file for some edits: In my case i found the file at /var/www/html/app/design/frontend/ThemeMaker/Theme/Magento_Theme/templates/html/header/logo.phtml

or just look for logo.phtml (ubuntu : locate -i logo.phtml)

just change this:

 <center><img style="width:215px; height:57px;" src="<?php /* @escapeNotVerified */ echo $block->getLogoSrc() ?>"
             alt="<?php /* @escapeNotVerified */ echo $block->getLogoAlt() ?>" /></center>

you can edit this code to look like :

<center><img style="width:215px; height:57px;" src="your-logo.png" alt="logos-Alt" /></center>
1
  • 4
    This is magento not static html. Dont do like that Commented Feb 9, 2018 at 7:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.