0

Even after disabling my custom module I'm getting this error. When I stopped working on it the day before this wasn't the case. It was working fine and I've been using this same server to develop for about 2 months with no issue like this. I verified I didn't change any major config files. I even tried upgrading magento itself and the exact same behavior continues everything works fine until you try to log into the admin or enable full page cache.

Spent at least 3 hours on this already anyone have any ideas? I get segmentation fault in messages for php-fpm. But I verified all the settings are correct and can even telnet to the php-fpm server. I'm not sure cause is but I verified the server runs fine even opened a phpinfo(); test page just fine.

1 Answer 1

1

I fixed it by taking the segfaults as a cue. I used this as a guide: https://ma.ttias.be/generate-php-core-dumps-segfaults-php-fpm/

After installing gdb and yum-utils so I could run the debug-info gdb prompted me to it all worked and I found it was calling the redis module just before it crashed. I disabled it and set sessions to be saved to files, as well as the php.ini this made the full page caching work but admin logins still didn't work I had to fix another error for it, it was setting my session to expire before I logged in. I found the solution to that here: https://github.com/magento/magento2/issues/5309

first step: in your mysql databse find path "admin/security/session_lifetime" in table core_config_data. if the row doesn't exist create it. Set the value to 86400

second step: clean cache (remove var/cache)

After this everything was working great.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.