1

I have a store which has a custom backend configured in app\etc\local.xml where the frontname node is changed like so<frontName><![CDATA[custom]]></frontName>.

Normally this would generate URLs like this:

  • domain.com/index.php/backend/catalog_product/index

But on this shop the URLs look like this:

  • domain.com/index.php/admin/backend/catalog_product/index/

I an not familiar with the full history of this shop. So I don't know how this part is exactly configured like this. The problem is I can't use services which connect to a specific backend url.

I allready searched in the database and files for "admin" but this gives too much results obviously. I am still looking through the database results because it is possible to check those at least. I also did a check on core file changes. There are no changes to the core.

How is this configured? And how can I change it to the default way? I still want to use a custom backend url offcourse.

  • Have you checked server configurations, such as nginx? Or, if on Apache, the .htaccess? – Ricky Odin Matthews Jan 18 '17 at 11:46
  • I just checked the .htaccess. I did not check the nginx configuration, because I don't know where too look. It might be unnecessary to check it because I cloned the site to a (apache) test server by copying the files and db, and this copy also has the same problem. Do you have any further suggestions what I can do? – Akif Jan 18 '17 at 12:06
  • 1
    It could be the magento 'store code', as technically you're in the 'admin' store view. Can you check if System -> Configuration -> Web -> Use Store Codes in URL set to Yes? If so, try it on 'no' – Ricky Odin Matthews Jan 18 '17 at 12:10
  • @RickyOdinMatthews Yup, thats it! The store does use this function in the frontend so I need to configure this the right way. Thank you very much. – Akif Jan 18 '17 at 12:14
  • no worries, I've added this as an answer - if you could accept that would be greatly appreciated :) – Ricky Odin Matthews Jan 18 '17 at 12:19
1

It could be the magento 'store code', as technically you're in the 'admin' store view. Can you check if System -> Configuration -> Web -> Use Store Codes in URL set to Yes? If so, try it on 'no'

  • This does solve the URL problem for the backend. But I need to use the storecodes in the frontend. I see I can't configure this on storeview level. Can I configue this in such a way so I do use the storecodes in frontend and don't use them in the backend? – Akif Jan 18 '17 at 12:23
  • Unfortunately not, this is a Global setting in Magento. The 'admin' you're seeing would normally appear as admin/admin on default settings. – Ricky Odin Matthews Jan 18 '17 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.