0

i had to re-install a backup recently and since i have not been able to receive order emails and customer dont receive them either.

i have uploaded AOE Scheduler and it says No heartbeat task found. Check if cron is configured correctly.

On the server the cron job is set to php -f /home/username/public_html/cron.php *5****

The file permission for cron.php is 744 The file permission for cron.sh is 644

In setup Instructions it has these settings sudo crontab -u timportsco -e

          • ! test -e /home/timportsco/public_html/maintenance.flag && /bin/bash /home/timportsco/public_html/scheduler_cron.sh --mode always
          • ! test -e /home/timportsco/public_html/maintenance.flag && /bin/bash /home/timportsco/public_html/scheduler_cron.sh --mode default

I dont have ssh access only through cpanel Which files need changing.

In mysql cron schedule everything is pending and has been form hours.

Please can someone help

0

1) Check your server email logs if possible.

I dont believe sales emails are sent through cron so it might be an issue with server or your domain settings (TXT/MX/DNS records)...

EDIT: ah its 1.9...sorry, seems like a cron issue then.

Here is magento article on how to setup cron:

http://devdocs.magento.com/guides/m1x/install/installing_install.html#install-cron

2) Also try using MXTOOLBOX:

http://mxtoolbox.com/domain/

and check your domain health. You can find some really good pointers there.

3) See if Return-Path is specified:

System-> Configuration-> Advanced-> System-> Mail Sending Settings-> Set Return-Path

a lot of mail servers seem to need that turned on (use Specified option since there is a Zend bug out). Otherwise all emails are sent right into spam folder.

EDIT:

4) Permissions and Users: it could be that permissions are not set properly for cron.php

Check both permissions and users that are allowed to trigger cron.php.

Permissions should be set to 644 and username must be your server name (ps -o "user group command" -C httpd,apache2).

Sometimes when you re-upload files using ftp it will reset the permissions AND the user at the same time to w/e your FTP software provides.

0

Here are a few things to check first of all if you access your cron.php using its direct link http://www.yoursite.com/cron.php does the heart beat show as run if so that means your cron.php is running correctly and it may just be an issue with the way your server executes the cron so first of all your permissions should be

Folders: 755 Files: 644

secondly if you can access the cron via the browser then setup the cron using

 /usr/bin/wget -O /dev/null http://www.yoursite.co.uk/cron.php 

set up the cron to run every minute which is * * * * * if this works perfect all sorted then you can change it to */5 * * * * if this doesnt work would you be able to provide your hosting company name as they may have a different setup

if you get error when accessing cron.php fron the browser thengo into your .htaccess and remove the following

###########################################
## Deny access to cron.php
    <Files cron.php>

############################################
## uncomment next lines to enable cron access with base HTTP authorization
## http://httpd.apache.org/docs/2.2/howto/auth.html
##
## Warning: .htpasswd file should be placed somewhere not accessible from the web.
## This is so that folks cannot download the password file.
## For example, if your documents are served out of /usr/local/apache/htdocs
## you might want to put the password file(s) in /usr/local/apache/.

        #AuthName "Cron auth"
        #AuthUserFile ../.htpasswd
        #AuthType basic
        #Require valid-user

############################################

        Order allow,deny
        Deny from all

    </Files>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.