1

On my previous upgrade the required value for my customer attribute was set to false. This was set in this file upgrade-1.0.0-1.10.php. Now i need to set it to be true. So I created my file: upgrade-1.1.0-1.1.1.phpand put this code:

$installer = new Mage_Customer_Model_Resource_Setup('core_setup');
$installer->startSetup();
$installer->updateAttribute('customer', 'medical_location', 'required', true);
$installer->endSetup();

Then I went to my config xml and I changed the value from 1.1.0 -> 1.1.1. I checked in the core_resource and it was updated to my current version. But the required value for my customer attribute is still false. Did I do smth wrong ?

Thx

3
  • Your last version is mentioned as 1.10 is it 1.10 or 1.1.0?
    – Mujahidh
    Jan 16, 2017 at 11:36
  • 2
    actually i fixed it , It was my fault . Instead of required I put is_required. Jan 16, 2017 at 11:53
  • please put your comment as answer
    – Amit Bera
    Jan 16, 2017 at 12:36

1 Answer 1

1

I fixed it by changing the required to is_required. Thx

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.