0

My php version is 5.6

PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/20131226/php_curl.dll' - /usr/lib/php/20131226/php_curl.dll: cannot open shared object file: No such file or directory in Unknown on line 0

After each magento2 command i am getting above warning, and in my custom module i am getting 500 internal server error while connecting to controller. But at other system with php version 7, my module is working fine. Is this error and warning is related to each other? What is the exactly solution of this? Please explain anybody

2
  • 1
    Magento 2 is designed for php 7+, why not update it? Jan 13, 2017 at 21:13
  • You need to install curl extension for your php version. However, not sure if that Magento2 version you are using supports php5.6, I don't think so Jan 23 at 8:56

2 Answers 2

0

In your php.ini you need to do the following as you don't have that extension installed. You can also download the extension with most versions of PHP

Find

extension=php_curl.dll

Change to

;extension=php_curl.dll
-3

Try these two commands in SSH in your Magento root directory:

php bin/magento cache:flush
chmod -R 777 pub var app/etc
1
  • his warning clearly states issue is connected to curl lib. it has nothing to do with cache or permissions Oct 12, 2018 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.