3

Is there any way to filter products grid collection in the admin > Product > Catalog grid by category Magento 2.1+?

I would like to filter products that are within a filtered category.

There seems to be a few examples of how to add Category column to the Grid however, I have tried 3 separate examples, and none of them seem to work.

  • take into consider that Product can be assign to more thn one category – Gopal Patel Jan 13 '17 at 6:52
  • I also have a similar problem. Could you help me to solve, please? magento.stackexchange.com/questions/173195/… – Trang Lee May 8 '17 at 2:12
  • Buy Amasty's Grid editor, it adds all sorts of sort functions including categories. – Spyrule May 8 '17 at 16:09
5

Even if this is an old thread there is still no free solution... So I've created a free extension that adds the feature of category filter in the admin product grid.

https://github.com/utklasad/magento2-admin-product-grid-category-filter

Cheers!

  • Hi i have installed your extension, but when i click on the catalog in admin panel i'm getting this error {"0":"Recoverable Error: Argument 1 passed to Utklasad\\AdminProductGridCategoryFilter\\Model\\Category\\CategoryList::__construct() must be an instance of Magento\\Catalog\\Model\\ResourceModel\\Category\\CollectionFactory, instance of Magento\\Framework\\ObjectManager\\ObjectManager given, called in \/var\/www\/html\/work\/hoodmart\/vendor\/magento\/framework\/ObjectManager\/Factory\/AbstractFactory.php . Can you help me please. – Karthickeyan Aug 30 '18 at 13:24
  • 1
    I have fixed it. app/code/Utklasad/AdminProductGridCategoryFilter/Model/Category/Categorylist.php. in this file change the class name from CategoryList to Categorylist – Karthickeyan Aug 30 '18 at 13:31
  • Ah, sorry for the typo there... I will fix it in the repo. Thanks! – utklasad Aug 31 '18 at 14:12
  • I'm using magento 2.3, there is not showing in admin. i have done all steps of installations. but now showing in admin. – Wajahat Bashir Sep 30 '19 at 6:51
  • It's working fine in Magento 2.3.2 for me. The position of the filter might have changed compared to the screenshot in the readme. Please take a double look and open a issue at GitHub if you still are experiencing problems. – utklasad Oct 1 '19 at 8:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.