I have a configurable product with 6 simple products associated. The configurable product has 2 options, color and size. Color is set as black option, with size being selectable.

I have checked as many of the suggestions and all of my settings seem to be proper, and they are showing as associated in the admin panel.

I also have a number of other configurable products with different number of options.

All configurable products are showing the associated products but they are only showing the first 4 of the associated products.

Is there a setting that I'm missing that limits/sets the number of the associated products that are displayed on the front end? Possibly a setting that indirectly affects this?

EDIT I tested the "limit/set" theory and it seems that even after disabling 2 of the associated products in the configurable product, the last 2 are not showing. I double checked all settings with the last 2 simple products and they are identical to the products that are visible on the front end.

Does someone out there know if there is some kind of "bug" with size options? For all my products, the XXL and XXXL will not show as options as of now.

  • All your single product have quanitity ? check this ->go to configuration product ->click on configuration->here listed all the products , all 6 are listed ? also all 6 product have quantity. The product which is not showing check its quanitity it must be a more than 0 and status is in stock Jan 10, 2017 at 6:01
  • Dave, all are listed, all have stock. Thats why I'm wondering if theres a setting. All cobfigurable products are showing up 4 associated on the front end, almost like its being limited by some sort of setting.
    – Jason
    Jan 10, 2017 at 6:06
  • okay can you please post the screenshot of front end ? where only 4 products are showing up Jan 10, 2017 at 6:10
  • @ManthanDave i'm on my desktop and I don't see the insert image button. Also, I'm editing my question.
    – Jason
    Jan 10, 2017 at 21:45

4 Answers 4


After going through all the attribute selections the answer lies in STORES->ATTRIBUTES->PRODUCT

Apparently, using the default Size options was OK without a label per option. There was no label defined for the size options S,M,L,XL which apparently is OK (those options still showed up on the front end).

But adding my own options (XXL, XXXL) and not properly adding a label in the Attribute options area, stopped them from showing.

I went into the attribute (size) options area and added the appropriate labels to all attribute (size) options, and they showed up on the front end.

  • I am getting the same issue, kindly share the screen-shot if possible or elaborate more. Jan 3, 2018 at 5:58
  • Adding the +1 because as of Magento 2.4.x still happens and I would like someone like me to find this answer sooner. I did the same and it worked, I was importing a csv with a custom script and even if I run the indexer, they went lost or ignored or I don't know...
    – YourTeam
    Jan 26, 2022 at 14:58

My solution was yes to Use in Search Results Layered Navigation and filling out Manage Options (Values of Your Attribute)

The site has been fine without but for some reason after update to Magento ver. 2.1.6 I had problems.

Also make super sure you never have duplicate URL's another issue


I have another type of issue. We were creating products by script in Magento 2 site. The problem was some times configurable products do not show all the available options.

Associated simple products was all correct they all were in stock ..etc.

After checking many threads I just save my configurable attribute and it started working correct. We did try many ways to search in code but it may be magento 2 issue of attribute configuration.


We are also getting the same issue in Graphql response. My website is on 2.4.3-p3 version and we are not getting all the options for a configurable product in graphql response. All the simple is identical related to stock and other settings but still some random simple product are getting in response of the graphql. Can anyone resolve that issue yet?

In Graphql response configurable_options array for Size attribute not return all the sizes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.