0

yesterday I got an error on my website, something like "Unable to handle this request". Sadly, I did not backup my website in the last weeks and I didn't want to lose my recent changes by using the backup, so I went to my Webhosts Account and saw that I passed the 50,000 file limit, with about 100 files. I thought the website's error was because of the host and that they closed my website because I had more than 50,000 files. To fix the problem I deleted the var/caches, var/reports and var/session folders from Magento. The next day, the error still was there. I pasted this code in my .htacces file, to see what the error was:

PHP error handling for development servers
php_flag display_startup_errors on
php_flag display_errors on
php_flag html_errors on
php_flag log_errors on
php_flag ignore_repeated_errors off
php_flag ignore_repeated_source off
php_flag report_memleaks on
php_flag track_errors on
php_value docref_root 0
php_value docref_ext 0

php_value error_log /home/path/public_html/domain/PHP_errors.log [see footnote 3] # php_value error_reporting 999999999 php_value error_reporting -1 php_value log_errors_max_len 0

After pasting the code, my website's error message changed to this:

Warning: include_once(/home/tastatur/public_html/includes/src/Mage_Core_functions.php) [function.include-once0]: failed to open stream: No such file or directory in /home/tastatur/public_html/app/Mage.php on line 36

Warning: include_once() [function.include0]: Failed opening '/home/tastatur/public_html/includes/src/Mage_Core_functions.php' for inclusion (include_path='/home/tastatur/public_html/includes/src:.:/usr/lib/php:/usr/local/lib/php') in /home/tastatur/public_html/app/Mage.php on line 36

Warning: include(/home/tastatur/public_html/includes/src/Mage_Core_Model_App.php) [function.include0]: failed to open stream: No such file or directory in /home/tastatur/public_html/includes/src/Varien_Autoload.php on line 94

Warning: include() [function.include0]: Failed opening '/home/tastatur/public_html/includes/src/Mage_Core_Model_App.php' for inclusion (include_path='/home/tastatur/public_html/includes/src:.:/usr/lib/php:/usr/local/lib/php') in /home/tastatur/public_html/includes/src/Varien_Autoload.php on line 94

Fatal error: Class 'Mage_Core_Model_App' not found in /home/tastatur/public_html/app/Mage.php on line 670

What should I do to fix the errors?

0

You should be able to turn off compilation to fix your error. see this answer.

To summerize though you can either run the following from the magento root in your cli:

php shell/compiler.php disable

Or edit includes/config.php and comment out the following lines:

#define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src');
#define('COMPILER_COLLECT_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'stat');
  • I've done this and now I am able to acces my website, but it seems that my friend can't acces it and gets the same error. – Vlad Jan 8 '17 at 16:22
  • It could be a cache issue, try clearing all your caches again. I don't see a reason why compilation would be off for one user but not others. – Andrew Kett Jan 8 '17 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.