I am facing some strange issues in Magento 2.1.3, i have configured third party theme and working fine, once i run setup:static-content:deploy, am getting fatal errors like i added below from core code. if we solve one error then it is throwing other errors.

I found same issues here MAGETWO-51440, even my code had the changes.

Fatal error: Uncaught Error: Call to undefined method ReflectionParameter::isArray() in \vendor\magento\framework\Code\Generator\EntityAbstract.php:324

Can any one help me on this strange issue.

  • Which is your application mode? – Khoa TruongDinh Jan 6 '17 at 12:45
  • @Khoa TruongDinh , Current application mode is default. – Krishna ijjada Jan 6 '17 at 12:46

Could it be a problem with the theme?

I would also try running in developer mode as this will generate the files on demand, and try deleting pub/static/frontend and var/view_preprocessed.

  • We are running the application in multiple local systems, there the same theme is working fine. We are facing this issue when we deploy static content alot. As I added MAGETWO-51440 link in the question – Krishna ijjada Jan 6 '17 at 17:18
  • All I can suggest is deleting var/generation, var/cache and var/di. If that doesn't work it could be related to sample data if you have that installed? Other than that I'm out of ideas sorry. – Ben Crook Jan 6 '17 at 17:20
  • I have removed the files and tested but no luck, yes I have my local application with sampledata. @Ben, Inputs are appreciated, thanks. – Krishna ijjada Jan 6 '17 at 17:25
  • Damn it, apologies I can't help more. – Ben Crook Jan 6 '17 at 17:25
  • 1
    Glad your response on my question. Will try in few more ways. Thank you so mush. Please reach me Linked in : krisnaijjada. – Krishna ijjada Jan 6 '17 at 17:29

You can compile

php bin/magento setup:di:compile

Then after that deploy static contents.

I think this happens when more than one entities tried to modify the same file(s) including the databases. I don't know for sure. but doing this fixed the error for me. Alternatively you can do the complete steps,



is optional.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review – Priyank Aug 16 '17 at 9:19
  • i had the same issue. and doing as I said fixed it – Vishwa Aug 16 '17 at 10:54
  • It didn't work for me – Mohamed Saleh Aug 4 '18 at 21:00
  • @MohamedSaleh before running compile command, remove the content in var and pub->static director. (rather than removing them, you can compress files intoa zipped file and keep it as a backup) – Vishwa Aug 6 '18 at 4:24

Run the following command stem wise

rm-rf var/*
rm-rf pub/static/*
php bin/magento setup:static-content:deploy
chmod -R 777 pub/static/ var/

it will help you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.