1

I recently created a Development/Staging copy of my site/database and everything seems to be working correctly on the front end. So when I visit dev.mysite.com I am able to browse my store and it stays on dev.mysite.com.

But when I try to login/access the admin area at dev.mysite.com/admin/ it keeps redirecting me to www.mysite.com/admin/

I updated my core_config_data table in the Dev DB for both secure and insecure url's to dev.mysite.com/. I know that the front end is using the dev DB because I update my local.xml.

I can actually access dev.mysite.com/index.php/admin/system_config/edit/section/web/... but i have to manually change the URL in the address bar. When I click around the admin area it always sends me back to www

I am also noticing that in the Dev Admin when i navigate to System>Configuration>Web>Base URL it is still showing www.mysite.com/ which is leading me to believe that the Dev admin area is still using the Production DB and not the Dev DB.

Is there some sort of caching or setting(s) that I am not aware of?

Please help. Thanks.

1
  • Clear Magento cache, check in core_config_data for all store view and clear browser – St3phan Jan 5 '17 at 22:17
2

Resolved. Since Im using a multi-store setup, it seems it was an issue with my HTACCESS along with the Secure URL in core_config_data. I had to set my Secure Base URL to http since my certificate does not support the dev.mysite.com domain. Here are my new settings

Development/Staging Site

HTACCESS:

SetEnvIf Host dev\.mysite\.com MAGE_RUN_CODE=mysite_com
SetEnvIf Host dev\.mysite\.com MAGE_RUN_TYPE=website

DATABASE core_config_data

web/unsecure/base_url = http://dev.mysite.com/
web/secure/base_url = http://dev.mysite.com/
0

Check that all of your base URLs in the core_config_data database table have been updated to your dev site's url.

This article explains how to do this: https://magento2.atlassian.net/wiki/display/m1wiki/Update+Site+URL+in+core_config_data+after+you+move+to+a+new+server+or+change+domains

1
  • Ok, I cleared the /var/cache/ dev directory and updated web/unsecure/base_url and web/secure/base_url to the new dev URL in core_config_data and still same issue. I did see a folder called /var/minicache/ would that need to be cleared as well? – Hector Jan 5 '17 at 22:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.