1

I am using magmi datapump (Magmi version 0.7.18) to import products into Magento 1.7 from an xml feed, and I have a problem with product descriptions. The product descriptions in the xml feed contain html tags (example below)

<div><span style="font-family: arial; font-size: 10pt;">Design-ul carcasei Procell      <strong>TPU Dual Bubbles</strong> este gandit atat pentru aspect, cat si pentru protectia impotriva loviturilor puternice. Canalele circulare din interiorul carcasei preiau socul loviturii, protejand astfel spatele iPhone-ului cu eficienta </span></div>

The relevant line for the description in my import script is:

'description' => base64_decode($record->Descriere)), // decodes the full description from xml feed

When I run the import script, the product descriptions are correctly imported into Magento and show up in the product description field (with html tags). However, on the frontend the html tags are not parsed, so the description shows up with html tags. I have checked the description attribute and both Allow Html tags on fronted and Enable WYSIWYG are enabled. I've also checked the template files and the htmlspecialchars function is removed from the product description.

The weird thing is that if I edit a product in the admin interface and save it manually, the html in the description renders correctly on the frontend, but I can't manually save every product. I've checked the database values for the description attribute on a product before and after saving manually and there were no changes.

Furthermore, I've imported the same html descriptions with Magento Dataflow and the html renders correctly on the frontend (without needing to save the product manually), so I guess there is a problem with the way Magmi handles html in descriptions, or there is a bug in Magento.

I've also tested on Magento 1.8 and the behaviour is the same.

Any help will be greatly appreciated. Thank you

closed as off-topic by Sander Mangel, 7ochem, kab8609, Keyul Shah, Amit Bera Mar 16 '15 at 14:39

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced OR seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Sander Mangel, 7ochem, kab8609, Keyul Shah, Amit Bera
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Try rebilding your indexes. – Marius Feb 19 '14 at 9:25
  • Hello Marius, I've tried rebuilding all indexes, flushing the cache, manually deleting the cache from var/cache, nothing works except saving the product manually. – Clain Alexandru Feb 19 '14 at 9:27
  • damn...I'm out of ideas. – Marius Feb 19 '14 at 9:44
  • This is how the description shows up imageshack.com/a/img843/3023/wjb2.png - notice the question marks inside the tags, even though the html markup is correct. – Clain Alexandru Feb 19 '14 at 9:57
  • 2
    This question appears to be off-topic because it is about a third party module. Please contact them directly for support – David Manners May 22 '14 at 7:30

Browse other questions tagged or ask your own question.