0

I've seen a lot of people with this issue when trying to create a custom indexer but my issue is on a brand new install V1.9.3.1 with sample data.

When attempting to save any settings in the admin panel OR when viewing the index management screen i get:

There has been an error processing your request

Indexer model should extend Mage_Index_Model_Indexer_Abstract.

I've tried clearing the cache & checked permissions but all seems to be fine, frontend of the store is working correctly.

Any ideas why the indexer isn't working?

Thanks

  • share your model code – sandip Jan 4 '17 at 13:02
  • the model code should be un-altered, where do i find it? – Ben Jan 4 '17 at 13:10
  • you create custom indexer, share that custom code – sandip Jan 5 '17 at 5:05
  • no, sorry for confusion, as it says in the question i've seen this issue using a custom indexer. The indexer i'm using is the regular one, brand new install V1.9.3.1 with no custom code – Ben Jan 5 '17 at 9:38
0

Fixed this issue by re-uploading the /app/code/core/Mage folder straight from the default magento install.

Magento install taken from the release archive here - https://magento.com/tech-resources/download

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.