I'm just getting familiar with Magento after many years of using X-Cart, and after not working on my test site for a two weeks it developed a problem.

None of the SAVE CONFIG buttons, or the ability to save anything for that matter, now works on the site.

I successfully installed the PHP 5.4 Patch, the APPSEC-212, patch for the CMS, and the SUPEE-2725 patch for Discover Card validation, but now little seems to work. I reverted the files and that made no difference, so I do not believe this is patch related, although it may be a server setting somewhere. (The server is running CentOS 5.10 x86-64 standard)

I was able to clear the cache files (those buttons worked), but any type of content or config update does nothing. No error message ... nothing. I also tried using different browsers (Chrome, Firefox, Opera, even IE), and all are the latest releases. Latest versions of Java and Flash are also installed.

The system I work from is Windows 8.1, which may matter, but it was working fine just over a week ago.

Also, Dev Logging is turned OFF and I cannot turn it on. Where is this switch located in the database, and I will manually enable it?

Any ideas or suggestions?


UPDATE # # # # # # # # # # # # # # # # # # # # # # #

This is what I'm seeing:

GET XXXXXXXXXXXXXXXXXXX/js/prototype/validation.js 404 (Not Found) (index):32

Uncaught ReferenceError: Validation is not defined js.js:606

Uncaught ReferenceError: Validation is not defined form.js:117

Uncaught ReferenceError: Validation is not defined form.js:34

Uncaught ReferenceError: Validation is not defined (index):3181

body.scrollTop is deprecated in strict mode. Please use 'documentElement.scrollTop' if in strict mode and 'body.scrollTop' only if in quirks mode. tools.js:343

body.scrollLeft is deprecated in strict mode. Please use 'documentElement.scrollLeft' if in strict mode and 'body.scrollLeft' only if in quirks mode. filler.js:1359

# #

When clicking on the "SAVE CONFIG" button I receive this error:

Uncaught TypeError: Cannot call method 'submit' of undefined (index):771

UPDATE 2014/02/19 # # # # #

Both the validation.js and validation.js.orig files are in the proper location.

Folder permission is 755 and file permissions are set to 644

NOTE: This installation has no additional extensions or themes, so there should be nothing other than default Magento making any changes to anything.

  • Check your console for javascript errors - those buttons require it.
    – benmarks
    Feb 19, 2014 at 0:07
  • Note in my post that error logging is off, so I do know where to view the error logs without first being able to enable logging.
    – SamS
    Feb 19, 2014 at 4:08
  • console = javscript console = browser. :-)
    – benmarks
    Feb 19, 2014 at 13:10

3 Answers 3


Your issue i this:

GET XXXXXXXXXXXXXXXXXXX/js/prototype/validation.js 404 (Not Found) (index):32

Please check if the file exists on your server and you can access it from outside. Both patches should not affect the JS folder, maybe during some copying or whatever you accidently removed/changed them or the access-rights are not set correctly.

The validation.js is basically needed everywhere and provides support for client-side form-validation. It's necessary to have it in your Magento installation.

  • Thank you for adding to this. The validation.js and validation.js.orig files are in the proper location with 644 permissions. The Prototype folder itself has 755 permissions.
    – SamS
    Feb 19, 2014 at 18:06
  • @SamS are you able to copy the URL and browse to it and see the source of the validation.js file?
    – jesseconnr
    Feb 19, 2014 at 19:21

I appreciate all the help figuring this out, and I would click the "useful" arrows on both contributors if I had the capability to do so (not enough reputation yet). Thank you!

I have found the problem!

I performed a little more research by checking other files in the same "prototype" folder, and I was able to access each of those in a web browser without error -- except for the second file, validation.js.orig.

Somehow, both of the validation.js files had ownership changes from the user associated with that domain to ROOT. Changing the ownership back to where it was supposed to be solved the problem. NOTE: After finding this solution I checked to make sure nothing else had incorrect ownership. I'm not sure how this was changed on just these two files.

  • glad this is fixed, feel free to accept this answer if you want to May 21, 2014 at 15:15

As Ben Marks points out - the buttons rely on Javascript to work. Sometimes installing modules and/or customising Magento can cause Javascript errors - from then on certain JS scripts will not run.

Open your browser's Developer Toolbar (Firebug etc. - I prefer Chrome's built in one). In the Javascript console, it is likely to show you an error. This information will help you in fixing the submit button issue.


The issue definitely is that 404 your browser is getting. When you get that 404 from the GET request, can you copy and paste the URL into your browser window to see if you can access it?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.