7

I am trying to display product attribute on layered navigation but it's not appearing.

I have already selected the Use in Layered Navigation -> yes,but the attribute is not appearing on layered navigation.

6
  • did this attribute have products? Jan 3, 2017 at 11:45
  • yes , i have added 5 products.
    – rajat kara
    Jan 3, 2017 at 11:46
  • 1
    then re-index and clear cache will do the trick Jan 3, 2017 at 11:47
  • already did everything still not working.
    – rajat kara
    Jan 3, 2017 at 11:47
  • What is the input type of your attribute? Only those with the catalog input type of Dropdown, Multiple Select or Price can be used as filterable attributes. Aug 19, 2017 at 18:43

5 Answers 5

7

Lets say you have an attribute called manufacturer. Then you have 5 products with the same value for manufacturer (ex. Brand X) the the manufacturer attribute will not show on the Layered navigation since all the products have the same manufacturer value.

Unless you have 1 product with Brand x and the other 4 have Brand y then the manufacturer attribute will now show up on the Layered Navigation.

1

May be below are the reasons this attribute does not show up at layernagation:

Assume that you have flushed the cache and re-indexed.

  • May be the current collection doesn't have the item having this attribute value.
  • May be, you did not assign the attribute to the attribute set

    If the you have this type reason then you need assigned the attribute to to attributes Sets and add this attribute to some products

1
  • Hi Amit , Thanks for your answer but attribute is already assign to specific attribute set.
    – rajat kara
    Jan 3, 2017 at 11:48
1

Besides the attribute settings, you also need to check each category. I.E. the category needs to be anchored.

While editing the category, go to the Display Settings tab and check that Anchor is set to yes.

2
  • What is the meaning of that? It is only an option if i want to show 0 filters in the catalog view page o all filters with no option to select which one? Sep 5, 2018 at 11:56
  • @GianniDiFalco the anchor option is required to enable the layered navigation. docs.magento.com/m1/ce/user_guide/catalog/…
    – Alex Dinca
    Sep 5, 2018 at 14:01
0

Make sure your attribute has set to Filterable with results on Use in Layered Navigation enter image description here Also make sure your attribute type is Dropdown, Multiple Select and Price.

1
  • I have enabled both conditions but it's not working. May 4, 2021 at 21:55
0

I was facing the same issue but when I verified from demo data, all attributes are using the multiselect type. To give a try I changed to attribute type multiselect it works and started displaying in the Layered Navigation.

enter image description here

Result

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.