2

Here's my site: http://wholesale.navajomfg.com/

Yesterday I started receiving this error, it seems to happen whenever an addon module is called:

Warning: include(/home/navajo/public_html/includes/src/Clever_Cms_Model_Mysql4_Page.php) [function.include]: failed to open stream: No such file or directory  in /home/navajo/public_html/includes/src/Varien_Autoload.php on line 93

#0 /home/navajo/public_html/includes/src/Varien_Autoload.php(93): mageCoreErrorHandler(2, 'include(/home/n...', '/home/navajo/pu...', 93, Array)
#1 /home/navajo/public_html/includes/src/Varien_Autoload.php(93): Varien_Autoload::autoload()
#2 [internal function]: Varien_Autoload->autoload('Clever_Cms_Mode...')
#3 [internal function]: spl_autoload_call('Clever_Cms_Mode...')
#4 /home/navajo/public_html/includes/src/__default.php(23743): class_exists('Clever_Cms_Mode...')
#5 /home/navajo/public_html/includes/src/__default.php(23777): Mage_Core_Model_Config->getModelInstance('cms_resource/pa...', Array)
#6 /home/navajo/public_html/app/Mage.php(490): Mage_Core_Model_Config->getResourceModelInstance('cms/page', Array)
#7 /home/navajo/public_html/app/code/community/Clever/Cms/controllers/IndexController.php(10): Mage::getResourceModel('cms/page')
#8 /home/navajo/public_html/includes/src/__default.php(13872): Clever_Cms_IndexController->indexAction()
#9 /home/navajo/public_html/includes/src/__default.php(18235): Mage_Core_Controller_Varien_Action->dispatch('index')
#10 /home/navajo/public_html/includes/src/__default.php(17769): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#11 /home/navajo/public_html/includes/src/__default.php(20369): Mage_Core_Controller_Varien_Front->dispatch()
#12 /home/navajo/public_html/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#13 /home/navajo/public_html/index.php(87): Mage::run('wholesale', 'website')
#14 {main}

If I delete the Clever_CMS.xml from the /modules folder (disabling it) the site works but the error reoccurs whenever I visit a page that calls another module.

Furthermore, the Product pages are completely blank - no code or anything (see http://wholesale.navajomfg.com/wine-stopper.html)

Also, in the admin, the "Pages" page doesn't show any pages or the frame to add pages, etc. It's just blank. The other pages in the CMS section (like Static Blocks) works as usual.

All I did yesterday was change some directory and file permissions. I've done my best to reset them all. Still, I don't see how changing permissions would cause this!

I'm not much of a programmer but I can typically follow technical instructions. Please help if you are able! Thanks!

*SOLVED** I found the solution to this problem.

Flushed the cache, logged back out and back in Then enabled the Compiler and Recompiled. (in System/Tools/Compilation)

It worked. Couldn't believe how simple the solution was - I thought I really broke the site!

  • have you change in index.php file like this Mage::run('wholesale', 'website')? – Keyul Shah Feb 18 '14 at 16:57
  • The bottom of my index.php says: (#Varien_Profiler::enable(); if (isset($_SERVER['MAGE_IS_DEVELOPER_MODE'])) { Mage::setIsDeveloperMode(true); } ini_set('display_errors', 1); umask(0); /* Store or website code */ $mageRunCode = isset($_SERVER['MAGE_RUN_CODE']) ? $_SERVER['MAGE_RUN_CODE'] : ''; /* Run store or run website */ $mageRunType = isset($_SERVER['MAGE_RUN_TYPE']) ? $_SERVER['MAGE_RUN_TYPE'] : 'store'; Mage::run($mageRunCode, $mageRunType); – alex5390 Feb 18 '14 at 17:08
  • Remove that code and try to check it will working or not If yes then Error in Mage::Run – Keyul Shah Feb 18 '14 at 17:09
  • I removed the code that I pasted and then everything shows up as blank (no code in any pages) – alex5390 Feb 18 '14 at 17:15
6

Whenever an error message contains includes/src/ it is very likely that the new/updated code has not been compiled yet. To recover from this (especially if your back-end has become unusable) edit includes/config.php and change

define(‘COMPILER_INCLUDE_PATH’, dirname(__FILE__).DIRECTORY_SEPARATOR.’src’);

to

#define(‘COMPILER_INCLUDE_PATH’, dirname(__FILE__).DIRECTORY_SEPARATOR.’src’);

This will fix the errors due to non-compilation and you can rerun the compilation process from the back-end.

To avoid such errors in the future when installing/upgrading any extensions I recommend the following steps in our installation guide:

  1. Turn off Magento’s Compilation Mode
  2. Turn on Magento’s Cache
  3. Install the Extension
  4. Refresh Magento’s Cache
  5. Log Out of the Backend and Log Back In
  6. Rerun Magento’s Compilation Process

On a sidenote: If you ever wondered why aheadworks has a two step upload (it is for the same reason as Step 2).

  • +1 , Thank you solved the issue of mine – inrsaurabh Aug 1 '18 at 11:41
1

Magento compilation is enabled and code was not recompiled after installation/upgrade or removal of any Magento module/extension. You need to Disable Magento compilation by Navigating to System->Tool->Compilation

In case if you can't open this section, then you need to

  1. Uninstall the module you recently installed by navigating to http:///downloader/ .
  2. Disable compilation setting from System->Tool->Compilation section.
  3. Install the module now.
  4. Activate compilation settings if you want
  • how can we recompile we can not open admin panel ? – inrsaurabh Aug 1 '18 at 11:34
0

Trying to figure out if the module Clever_CMS is actually causing the error is a good place to start. You don't have to remove the xml file, you can just set the module to 'false'. The module xml probably looks something like this:

app/etc/modules/Clever_CMS.xml

<?xml version="1.0"?>
<config>
    <modules>
        <Clever_CMS>
            <active>false</active>
            <codePool>local</codePool>
        </Clever_CMS>
    </modules>
</config>

Note: disabling the module in the backend will only disable output, not the module as a whole.

You should probably also turn on logging. Go to System - Configuration - Advanced / Developer. Under Log Settings you can enable logging. This will generate log-files in var/log. If anything goes wrong, you're likely to find more information in system.log or exception.log.

Also, don't forget to clear the cache! You can do so in the backend, under System - Cache Management - Flush Cache Storage. Or you can delete the contents in the directory var/cache.

This should get you started in trying to debug this error.

  • Thanks for your help. Someone on Fiverr actually had the solution - just had to recompile! Dodged a huge bullet. – alex5390 Feb 18 '14 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.