0

I have used SMTP Pro extension for mails configuration. All emails works perfectly except email for order. Cron is setup correctly in server. Code to run on server is :

php -f /home/magento/public_html/project/cron.php

and I have setup cron to run on every one minute. For quick fixes what i did is change in order.php (public_html/app/code/core/Mage/Sales/Model/Order.php)

From

$mailer->setQueue($emailQueue)->send();

To

$mailer->send();

And the emails are sent instatly whenever customer orders the product instead of queuing. But, what i need is the order need to be send through cron. Can you suggest me the best way to solve this problem.?

Thanks.!

0

After installing that extension if you want that your mail should sent from cron then change below setting ,

Login admin panel and

go to system->configuration->Aschroder Extensions->Smtp pro-> Queue Configuration->Queue Usage 

And set for cron and your mail send from cron job your job is done

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.