1
  1. I have been facing strange issue, as the part moving modifications in static content. we removed pub/static and deployed setup:static-content:deploy.

  2. After doing this, files are generated properly in pub/static folder but when i load front end, styles are vanished.

  3. As in the source the file paths are loading with version1483082446

root/static/version1483082446/frontend/Smartwave/porto/en_US/mage/calendar.css

  1. I have followed below commands, but my styles are not loading in frontend.

 

Remove pub/static
Remove var/cache
Remove var/composer_home
Remove var/generation
Remove var/page_cache
Remove var/view_preprocessed
run php bin/magento setup:static-content:deploy

Any help would be appreciated.

  • Instead of removing all contents from pub/static remove the css file you made changes from that module and check again. – Nitin Pawar Dec 30 '16 at 7:52
  • Yes, but I removed/deleted now by following some stack posts, how can I proceed noe. – Krishna ijjada Dec 30 '16 at 8:06
  • is your problem solved? – inrsaurabh Jun 3 '17 at 5:15
2

You've actually removed the whole of the pub/static folder. Meaning you've also removed the .htaccess file from the static folder.

Re-add this .htaccess file which can be found here:

https://github.com/magento/magento2/blob/develop/pub/static/.htaccess

And your problems should be resolved.

0

You need to run following commands,

php bin/magento cache:clean
php bin/magento setup:static-content:deploy
chmod -R 777 pub/

If above command not give proper result, again run this,

php bin/magento setup:static-content:deploy
0

I had same problem after restoring the backup files to the new site. All static content were not loaded.

After coping the .htaccess from old site to pub/static folder it started to work.

Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.