2

Recently a critical remote code execution vulnerability in PHPMailer has been discovered, and that has been reported on https://www.wordfence.com/blog/2016/12/phpmailer-vulnerability/?utm_source=list&utm_campaign=122816&utm_medium=email which focuses on WordPress sites.

However I'd like to know if this can affect somehow Magento installations as well or not.

2 Answers 2

0

Magento uses Zend\Mail by default. Magento is built upon the Zend framework, and as such uses many of its components.

So, in short, this PHPMailer vulnerability doesn't apply to Magento.

0
0

Yes you can use PHP mailer with Magento

Refer : http://www.mrmagento.com/magento/mag-send-mimehtml-emails-with-php-mailer/

2
  • 1
    Sorry forgot to mention that I am talking about vanilla installation of Magento. Do you mean that Magento uses PHPMailer by default?
    – Antony
    Dec 29, 2016 at 9:24
  • Nope it does not use it by default. But you can use it manually. Refer the above link Dec 29, 2016 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.