1

I have a problem with the Order Confirmation emails not sending, all the others appear to be sending just not the Order confirmation ones.

I've installed AOE scheduler, and it's indicating that there is No Heartbeat task found and asks that I edit my cronab

sudo crontab -u new2magento -e

and add the following configuration

 * * * * * ! test -e /home/new2magento/public_html/maintenance.flag && /bin/bash /home/new2magento/public_html/scheduler_cron.sh --mode always
* * * * * ! test -e /home/new2magento/public_html/maintenance.flag && /bin/bash /home/new2magento/public_html/scheduler_cron.sh --mode default

I'm fairly new to magento and could really do with some help finding exactly where I have to add the configuration

0

This will depend on your hosting provider. Im assuming you dont have your own dedicated server or this is something you should already know. If your on cPanel there is a button somewhere for it. I dont use cPanel though. I use virtualmin and its under the webmin and look for the task acheduler

  • yeah it uses cpanel, there is a secton called cron jobs, but I don't really have any knowledge of what to do from there – New2Magento Dec 28 '16 at 1:46
  • Its asking you to set a cronjob with the command of test -e /home/new2magento/public_html/maintenance.flag && /home/new2magento/public_html/scheduler_cron.sh --mode always For every second of every hour of every day but this is hard on your system I would recommend it to run every 5 or 15 minutes to help reserve server resources – user47507 Dec 28 '16 at 1:52
  • so do I just copy and paste those lines as separate jobs and set them to every 5 mins? – New2Magento Dec 28 '16 at 2:15
  • Yes or go back to the installation instructions and setup the correct cronjob for the installation itself – user47507 Dec 28 '16 at 2:16
  • so copy ad paste * * * * * ! test -e /home/new2magento/public_html/maintenance.flag && /bin/bash /home/new2magento/public_html/scheduler_cron.sh --mode always ? or -e /home/new2magento/public_html/maintenance.flag && /bin/bash /home/new2magento/public_html/scheduler_cron.sh --mode always – New2Magento Dec 28 '16 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.