3

I am using magento data migration tool. When i try to run this code

bin/magento migrate:data C:\xampp\htdocs\xxxxxx\vendor\magento\data-migration-tool\etc\ce-to-ce\1.9.1.0\config.xml

It returns an error

[0;31m[2016-12-26 08:48:20][ERROR]: Source fields are not mapped. Document: customer_eav_attribute. Fields: is_used_for_customer_segment

There were other errors and I used map.xml to ignore them but it is not working for this error. I added this code block in my map.xml

<ignore>
<field>customer_eav_attribute.is_used_for_customer_segment</field>
</ignore>

But the error is still there. How can I fix this error?

  • have you tried with reset? or new database? also make sure you have correct file names in config.xml – MagenX Dec 26 '16 at 9:39
  • I started on a fresh magento 2 installation. I have linked the correct databases and map file. Do i need to add any other files in config.xml? – magento_practitioner Dec 26 '16 at 9:43
  • To get the solution for this error we are happy to help you:elsner.com/magento-2-migration-services – Elsner Technologies Jul 18 at 5:31
3

You need to edit the map-eav.xml.dist file to map fields in EAV tables. The main map.xml.dist file only handles mapping of non-EAV tables.

FYI, there are also a couple other sets of tables—for tier prices and customer visit logs—that have their own custom map files separate from map.xml.

0

I am getting below error while migrating data from magento 1 to magento 2. Can someone help me regarding this?

Error - php bin/magento migrate:settings vendor/magento/data-migration-tool/etc/opensource-to-opensource/1.7.0.2/config.xml

[2019-01-21 08:56:01][INFO][mode: settings][stage: integrity check][step: Settings Step]: started [2019-01-21 08:56:01][INFO][mode: settings][stage: integrity check][step: Stores Step]: started [2019-01-21 08:56:01][INFO][mode: settings][stage: data migration][step: Settings Step]: started [2019-01-21 08:56:01][INFO][mode: settings][stage: data migration][step: Stores Step]: started [2K100% [============================] Remaining Time: < 1 sec

[UnexpectedValueException] Invalid parameter configuration provided for $sourceDocument argument of Migration\RecordTransformer 

migrate:settings [-r|--reset] [-a|--auto] [--]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.