6

I just upgraded to Magento 2.1.3 and I'm getting the following error message when I go to the design configuration section:

SQLSTATE[42S02]: Base table or view not found: 1146 Table 'db.design_config_grid_flat' doesn't exist, query was: SELECT COUNT(*) FROM `design_config_grid_flat` AS `main_table` WHERE (`store_website_id` = '1') AND (`store_group_id` IS NULL)

1st UPDATE:

This is what happens after I run the indexer:reindex command

enter image description here

2nd UPDATE:

This is my list of tables in the database and you can see that there is no table to drop even though I get that error message from the reindex method enter image description here

3rd UPDATE:

This is what I see when I try to run the create table sql command enter image description here

  • Did you rerun console command indexer:reindex? – Max Jan 16 '17 at 18:53
  • @MaxStsepantsevich I updated my post to show you what it does after I run that command – user3610374 Jan 16 '17 at 19:00
  • it is database issue, not magento, try search answer by mysql error during reindex. This table is dynamic flat, you can remove it and reindex - table will be created anew. – Max Jan 16 '17 at 19:11
  • @MaxStsepantsevich This isn't just simply a database issue because it only happened after the upgrade to magento 2.1.3 and I see other magento questions with similar issues. I don't touch my database at all – user3610374 Jan 16 '17 at 19:52
  • @MaxStsepantsevich I updated my post to show the tables I have in the database and I can't remove it because it never shows up in the database, no matter how many times I run the reindex command – user3610374 Jan 16 '17 at 20:38
8
+50

Table is missing. Run in sql console below sql query. After run sql query run php bin/magento indexer:reindex

CREATE TABLE `design_config_grid_flat` (
  `entity_id` int(10) unsigned NOT NULL COMMENT 'Entity ID',
  `store_website_id` int(11) DEFAULT NULL COMMENT 'Store_website_id',
  `store_group_id` int(11) DEFAULT NULL COMMENT 'Store_group_id',
  `store_id` int(11) DEFAULT NULL COMMENT 'Store_id',
  `theme_theme_id` varchar(255) DEFAULT NULL COMMENT 'Theme_theme_id',
  PRIMARY KEY (`entity_id`),
  KEY `DESIGN_CONFIG_GRID_FLAT_STORE_WEBSITE_ID` (`store_website_id`),
  KEY `DESIGN_CONFIG_GRID_FLAT_STORE_GROUP_ID` (`store_group_id`),
  KEY `DESIGN_CONFIG_GRID_FLAT_STORE_ID` (`store_id`),
  FULLTEXT KEY `DESIGN_CONFIG_GRID_FLAT_THEME_THEME_ID` (`theme_theme_id`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8 COMMENT='design_config_grid_flat';
  • I was thinking that as well but the create table command doesn't work. I updated my post to show what I see when I try – user3610374 Jan 16 '17 at 23:50
  • Sounds like you have a design_config_grid_flat.ibd but no design_config_grid_flat.frm. Is missing design_config_grid_flat.frm file. – St3phan Jan 17 '17 at 17:11
  • Somewhere you've imported the database, or database is after installation magento ? – St3phan Jan 17 '17 at 17:12
  • I imported the database when I transferred the server but it worked after that and then I performed the upgrade to 2.1.3 and that is when it broke. If it is missing the design_config_grid_flat.frm file then where do I get that? – user3610374 Jan 17 '17 at 19:45
  • Do you have old DB ? before upgrade ? – St3phan Jan 17 '17 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.