0

Please help me with this issue I have been stuck with for quite a few days now.

The issue: Every time when I goto Magento admin panel (EE 1.14.2.3) under Manage categories and try to save a new category, the please wait gif pops up, the browser tab shows the loading/submission icon near the favicon for a few secs but does not actually refreshes. But the please wait gif stays there until I close the tab or reload the page. For now, this is the only place of the Admin panel where I encountered the issue. Tried the same in manage attributes and it did not hang up. The category is not created when I go back.

The problem seems to be related to the upgrade of 1.14.2.2 to 1.14.2.3 version. As reverting to the prior vers in other environments makes the issue go away.

There are no errors in the browser console, in the Magento logs and the server logs. Also I have tried the following: Extending the php execution time Changing index mode to run manual Cache is always set to No and Error display on.

What I have found during debugging is that after redirecting to Manage Category form there is a bit of js for form.submit in form.phtml (child call from adminhtml/def/def/template/catalog/category/edit.phtml). This js is supposed to deal with submitting the form for new categories. But right after redirecting to Manage Category, there is an ajax call immediately, and this Ajax call for some reason is wiping out this js part. The onload ajax is supposed to update content by fetching existing categories I believe. I have tried commenting the onload ajax call and tried to submit the form, but it still hangs up with the "please wait" screen, leading me to believe it is probably something with header, http or the js library.

If anybody has encountered something similar I would really appreciate some pointers on how I can debug this! Thanks.

0

I finally discovered the problem and it was with the patching process. This patch had a security update that was already applied and hence the patch was supposed to ignore the related files. For some reason however it did not ignore a file (lib/Varien/File/Uploader.php) and rewrote an already existing method. The class would not initialize as a result and the error did not show up for some reason! I discovered this with debugger going through the code.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.