1

I try to run Functional Testing Framework. When I run tests:

vendor/bin/phpunit

I see that new Firefox window is launched, .../admin/admin/ page is opened and login form is appeared on the page. But authentication is not performed. I see this error in the selenium server logs:

14:21:06.806 INFO - Executing: [get current url])
14:21:06.812 INFO - Done: [get current url]
14:21:06.835 INFO - Executing: [execute script: return document['readyState'], []])
14:21:06.850 INFO - Done: [execute script: return document['readyState'], []]
14:21:06.854 INFO - Executing: [execute script: return document['readyState'], []])
14:21:06.864 INFO - Done: [execute script: return document['readyState'], []]
14:21:06.870 INFO - Executing: [find element: By.cssSelector: .page-header .admin-user])
14:21:07.478 WARN - Exception thrown
org.openqa.selenium.NoSuchElementException: Unable to locate element: .page-header .admin-user

There is no '.page-header' element on the login page:

enter image description here

What I need to do to run functional tests using FTF?

1

I found out the problem. It deals with new version selenium server 3.0.1 and new Firefox version 50. The problem is following:

I have Firefox v50 and selenium server 3.0.1
This version of the selenium server ask web-driver, I run it using java -Dwebdriver.gecko.driver="path\to\driver\geckodriver.exe" -jar D:\etc\selenium\selenium-server-standalone-3.0.1.jar
But received errors:
Unable to locate element: .page-header .admin-user - in the server trace
moveto did not match a known command - in the test trace
Googled this problem I found that Actions Class not working with gecko driver - so I test couldn't login and returned the error about ".page-header .admin-user"
After I changed Firefox version to 46 and selenium-server to 2.53 everything works well

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.